Forum Academy Marketplace Showcase Pricing Features

Data not showing in preview

Hi there. Brand new to bubble, and am trying to preview a design I’m working on with some data I populated, but in my repeating group, nothing shows up in the preview, not dynamic text, not static text, not icon - it’s as if the group isn’t visible at all, but from the options I’m given it should be.
Also, I entered another text box on the page below the repeating group to see if I can get it to preview, but all it shows is “lorem ipsum” even though I do have data populated in the field I chose.


I’m trying out with the free version right now, so not sure if that has anything to do with it.
Any help is appreciated!

Hi there @FlowersByIrene,

Can you send a screenshot of what you have as your data source for that repeating group?

Data source:

Updated screenshot from repeating group, showing the field that it’s tied to:

Cell dynamic data:

Transaction data table:

Does that show anything wrong?

Are you privacy rules blocking this information from being shown?

Hi @juicebox ,
That seems to have been it, thanks for the suggestion! One question though, why am I not able to see my own data that I entered, is it because I’m listed as the “admin” and not a normal user?

Not sure how to test the app without turning off privacy rules I guess

@FlowersByIrene Just create a new privacy rule like ‘Current User’s Type is Admin’ and then give it full access. It will override this ‘Visible to creator’ privacy rule.

Thanks for the suggestion @juicebox , but I don’t seem to have that option when building the rule. I’ll keep digging…

Sure, you’d need to create the field on the User data type first.

In theory you would have normal users and then perhaps ‘Admins’. You would have a field on the User data type which categorised them. Then you can create a privacy rule around that.

The other option is instead of adding the Transaction manually within the editor, you could create it within the interface you’re building and therefore the ‘Created by’ field would be your email address, and it would show.

This topic was automatically closed after 70 days. New replies are no longer allowed.