Repeating group responsiveness problem

Hi people, first here is the visualization of the problem:


So, The group below is a standard section that I took from “components” and it already comes responsive.

I duplicated the section but I changed it to a repeating group. All the settings match exactly but the repeating group section is not responsive. What could be the issue and how can I make repeating groups responsive?

I searched the yt and everywhere and was shocked that there are all kinds of solutions for different issues but not for this exact one.

Obviously, there’s some option that will do the trick. If you want some concrete advise, provide screenshots of your setup.
It looks like fit width to content is enabled somewhere, if I’d have to bet.

1 Like

Change your min width to 0?

Or uncheck fixed number of columns. It used to be enabled initially…

  1. Here is a screenshot for Repeating group

  2. Here is the container inside RP

  3. Here is the Card inside container

Thank you for your help!

it is set to 0

Show Appearance tab of the Repeating Group on the very first screenshot, pls. And meanwhile you can play unchecking its “Fit width to content” option in the Layout tab.

Here is the appearance of RP

And when I uncheck fit width to content it squeezes all three cards together rather than showing one by one in column.

Its because you have set Fixed number of columns on RG.
Uncheck it and try again.
BTW, If you don’t want scroll bar to appear, uncheck both fixed rows and columns.
In other words just play around with these settings of the Repeatin Group:

  • fixed number of rows
  • fixed number of columns
  • fit width to content
  • fit height to content
1 Like

It worked! Thank you so much! I was so confused with this obviously simple thing that it made me almost quit bubble!