Reset Input not working

Hi bubblers,

I don’t know if it’s just me or a bubble bug but it seems “reset input” is not working. I just have a group with an input and a button in it. The button has a workflow to reset the input when clicked but it isn’t working. I have tried to see if it’s a problem within my app but I get the same issue in other apps. I have tried “reset input”, “reset data” but it isn’t working.

Hi @mikeolas :wave:
For me it’s working
I wrapped my input & button in same group then in the workflow i do like this


Screenshot 2022-09-05 at 16.56.10

If it doesn’t work for you then you can contact bubble support or submit bug report

3 Likes

Thanks… I just realized that the “Reset Data” action works (although, it didn’t earlier) but any idea why “Reset Input” isn’t working?

2 Likes

The ‘Reset Relevant Inputs’ action only resets inputs who’s values were used in the workflow (otherwise it wouldn’t know which inputs to reset)…

It doesn’t matter where/how they are used in the workflow though (even on an only when condition)… so you can try adding an ‘only when input’s value isn’t empty’ condition on the reset inputs workflow action… that should make it work.

Or you can put the input in a group then use Rest Data (as @viquarahmed07 suggests) instead.

3 Likes

That makes a lot of sense now… I was just reading the doc as your reply came in. Thanks for this explanation. Now, I know not to confuse both. :grin:

1 Like

Saved my night, thank you!

2 Likes

Hey Michael,

Bubble executes the reset relevant inputs action based on what it understands from the rest of your WF.
I’ve found a workaround for this by including the input in your reset input action - add it to the condition on that action.

So it would be something like Reset Relevant Inputs - only when Input A's value is not empty.
Works every time!

3 Likes

Hmm… I’ll also give that a try. Thanks @atomicfusion

1 Like

not every time. this isn’t working for me. the same input is also used in the Create in step 1.

i’ve often had problems resetting inputs, i’m not sure why it’s not a bigger issue for people.

Interesting. Maybe worth reporting to Bubble.

This topic was automatically closed after 70 days. New replies are no longer allowed.