[Resolved] Picture uploader broken?

Hello @josh @eve

Was there any work carried out on the picture uploader today? All my picture uploader elements stopped working. The image does not get loaded into the element, however if I hover over the element it will display the file name of the uploaded picture. This is both in the live and development versions. So I don’t think it’s related to me doing anything as I haven’t touched the uploaders, and it exhibited in live before I pushed a new version.

I might be hallucinating, but did the picture uploader icon in the elements section get a new icon?

If I add a new picture uploader, it seems to work, albeit with a slight delay. Hoping to not having to replace all my picture uploaders and attached workflows. :confused:

1 Like

You can check out any new releases they pushed here: https://bubble.io/releases

Sometimes it’s sort of vague, so I guess it is possible. Hard to tell. You can test it by re-creating the issue on a brand new test app. If it is still an issue, then you can make a bug report and show them that test app so they can re-create the problem.

Hope that helps! :blush:

@j805 www.NoCodeMinute.com

For All Your No-Code Education Needs:

  • One-on-One Tutoring
  • eLearning Hub
  • Video Tutorials
  • No-Code Classes

Thanks J805, yeah I did have a look there and saw that work was carried out, but as you say, hard to tell if it might have affected uploading pictures.

Yeah, as I mentioned. I tried re-creating it with a new uploader, which works. But that does not solve the issue of all the older uploaders no longer loading in the uploaded image. It’s a bit of a weird one.

Yeah, that is odd. Try just moving them one pixel and then pushing an update and see if that fixes it. So if you delete the uploaders and put in another one, it will work? That will be an irritating fix… hmm :thinking:

Moving it 1px? haha that’s an interesting idea, but no that unfortunately didn’t work. Yes, I’m using a number of uploaders with workflows and conditionals attached to them, so stripping them all out and replacing them would be at the very bottom of the list for solutions.

Tried clearing browser cache, and tried on a few different browsers. Will support a bug ticket instead.

1 Like

Mine are not working either. The upload bar keeps going, whether for camera or files

1 Like

Yeah, seems like a bug. Definitely send that report. :blush::+1:

One more odd thing to try too. Try deleting it and then pressing undo. That might reset it. :man_shrugging:t2:

That’s good to know. Thanks @deadpoetnsp

@J805 Ticket has been submitted. Your suggestion did unfortunately not solve the issue. I also tried “replacing element” with picture uploader to see if it would jolt it back into action, but no dice.

I confirmed this as well. Submitting a ticket too.

Bummer. :man_shrugging:t2: Well. I tried. Hopefully Bubble can push a fix soon for you. That’s pretty annoying. :blush:

You sure did haha. thanks @J805

We’re looking into this, more updates shortly

Thanks @josh

Okay, we think there’s a very high likelihood the problem is due to a deploy from 1:08 pm today. We’re reverting that deploy now, and expect it to be live in about ~7 minutes. We haven’t been able to reproduce the bug on our end yet, so I’d appreciate: a) confirmation that the reverting the code fixed it once it goes live (I’ll post again when it does), and b) any details you can send us (to support@bubble.io if it involves an app you don’t want to post on the forum) to help us reproduce so that we can identify the problem and re-deploy the offending code with the issue fixed

1 Like

@josh That would line up nicely with me first seeing it around 2pm when I tried to upload an image in the live app.

I did submit a bug report with repro steps for an app, but it might not have made its way in front of the team yet. I will keep an eye out for when the deploy and give it a go.


I can confirm that it’s working in my live app now, without me deploying a new version. So looks like you might have found the offending code there! Great stuff!

Works in development as well.

Great! Yeah, the fix went live a couple minutes ago. Glad it’s resolved for you, and really sorry about the inconvenience!


I confirm it’s working for our app as well now (www.plantswapper.com/sign-up)

@josh Thank you for the quick fix here.

1 Like