Issue displaying image already uploaded


I’m suddenly having this issue where I cannot display the image neither on the Picture Uploader itself, or on the image display element. It used to work fine before, but since this afternoon just behaving like this. I already tried on different browsers and still the same.

Does anyone have experienced this in the past? If so, please let me know how you solved. Thanks!

Image Display element

Picture Uploader Input

same issue experienced. No image displayed and upload unsuccessful

I’m sort of seeing the same. The picture uploader won’t show the uploaded photo. No changes made - just all of the sudden doing this. Sometimes it does load though… so, not sure.

Same issue here. I’ve tried through both the uploader on my app and the uploader on the Data tab for this object. Inspector shows the correct image as being there, but nothing displays in the image element.

Yep, having the same issue here. Only for newly uploaded images.

I am also having the same issue. Browser console shows 504 Gateway Timeout errors.

Has anybody filed a bug report yet?

I´m having the same issue over here. Just spent 40 minutes trying to troubleshoot before coming to check here :smile:

I am having issues with displaying an uploaded image (from the editor) as well

Same here, I sent a bug report just now.


Same here.
However, pictures can be accessed through the database.
If I go to the app data and check the picture field and click on “see”, I can see the uploaded picture.
It just doesn’t show in my app

Thanks, @Timon! Let us know if you get any feedback from Bubble. :slight_smile:

CC: @neerja


Still nothing, and since our whole app is based on the possibility to upload photos of car damage my complete business has been down for almost a day now.

@neerja @emmanuel would be good to have at least some kind of an idea when we can expect this to be solved. Even had to cancel some business meetings in which I was supposed to present our app.

Can we have an :sos: button here?


Same issue here.

Similar issues with my app.

Has anybody filed a bug report about this?

+1 with the same issue :confused:

Can someone share a link? It’d be easier to help with a link.

there you go: