Retrieving data

Hello… I have a Repeating group that displays all the chats that a user is a part of. That is the image below

When any one of these chats is click, it opens a group that holds the messages that are in that specific chat. The picture below shows this specific group

Here’s how I’ve set up the database.

I have a datatype called CHAT, this chat is created when a user clicks on the message icon of another user for the first time when there’s no chat that has them both as the users.

I also have another datatype called MESSSGES. This holds the actual messages in a specific chat. So when a specific chat is clicked, these messages populate that chat.

I updated bubble to the latest update this morning and my chat can’t seem to retrieve the messages associated to it. When a message is sent in a specific chat, it appears for like 2 minutes and disappears.

I do not know if I’ve messed up somewhere or its somehow caused by the update because it previously worked fine until this morning.

Any help is very much appreciated. Thank you!!!

Hi there, @ericwillcampbell3… if everything worked fine until this morning and it only stopped working after you did the upgrade, you could try reverting to the previous version to see if that fixes it (and if it does, you would be pretty darn sure it is related to the upgrade). I would also suggest that you submit a bug report, if you haven’t done so already.


1 Like

Okkk… I’ll try those and see how it goes

I did revert it back to the previous version but the challenge still persists so I’ve sent in the bug report as you suggested. What I do not get is that the database data is still there. The repeating group is mysteriously unable to fetch it.

Any chance privacy rules are getting in the way?

What changes did you make from the time when it was working until the time when it stopped working? Can you revert your app back to the time when it was working?

You’re right, I had privacy on there but I also had condition on the privacy rules to. Thank you soo much for your help. Everything worked well when I removed them.

1 Like