RGs & "Do a Search for" not updating without refresh today (2)

Starting a new thread since this bug was back with a vengeance today and the previous thread (http://forum.bubble.io/t/rgs-do-a-search-for-not-updating-without-refresh-today) expired.

This issue was terrible in my app today, causing lots of issues for our users. Maybe worst I’ve ever seen it.

Something else I’ve thought of though that could alleviate this, is a feature that’s been requested before, which is a way to force refresh RGs.

Even if this particular bug is fixed, there are still lots of nasty caching issues, particularly in mobile Safari, that block the auto refresh. Having a way to force the refresh manually would not only be a short term fix to this bug, but also any and all other auto-refresh blocking bugs.

Here are some other threads on this feature/other rg refresh bugs:

The auto refresh ability of Bubble RGs is cool, but it’s never been truly reliable 100% of the time, and there’s no reason for us to believe it ever will be in the future. So does it not make sense to provide the ability to manually trigger refreshes as a backup?

Thoughts? @josh


Thanks @aj11 , yeah I have been hoping for same feature itself too. In fact some good soul had put it up on Ideaboard too, but had not received much traction unfortunately.

Sharing screenshot as ideaboard ideas don’t have url to share.

By the way, for me the issue is not limited to having new data not getting updated in RG. What also happens is that wrong data is shown in the table because of broken connection or whatever. So for example if it is a repeating group that shows a list of tasks, then in the row of tasks one column will belong to one task, another to another task etc. It quadruples the confusion and issues.

PS: Also, I think there are some kinds of threads (don’t know which kind) which don’t expire. Maybe we should figure that out and post one of that kind.


We need people to go upvote this and get more attention to it.

Scroll down a bit to load more of the page, then search for “Add a workflow action called” and it will come up.

I don’t understand how we’re supposed to build reliable apps on Bubble with RGs that don’t auto-update and we can’t force to refresh. Debilitating.

At least give us the ability to force the refresh to account for the times when it’s not working.

1 Like

Hi, I just upvoted the Add a workflow action called “Refresh repeating group”
The right link is “https://bubble.io/ideaboard

Looks like it’s been taken down?? When you go to the link it redirects back to Bubble’s home page.

nope :slight_smile: if you simply paste here the url, the “/ideaboard” part gets cancelled. If instead you paste the url using quotes (“url”) it pastes the complete url: “https://bubble.io/ideaboard

Ahhh I see. Thanks!

anyone else still having problems? Its not updating at our end…

1 Like

Seems to be alright for us today at least. Any update on the fix @josh?

I upvoted this idea too!

Yeah, so the second band-aid fix we tried worked, and the problem hasn’t occurred again since. We don’t think this fix will last forever, and are still working on the long-term fix, but so far so good.

For users such as @gaimed who are still seeing a problem, it may be a different issue than the one we’ve been looking into, so I encourage opening a bug report with details about your specific app if you haven’t already to make sure it gets on the team’s radar.

I’m passing on the force-refresh feature idea to the team. It’s an interesting idea, but I’m not sure if it would solve caching issues, since those tend to be at a layer below our code; we’re already trying to force a refresh whenever we detect the data in the repeating group is stale. More likely, the best route forward there is for us to find a workaround to the caching problems that makes our existing real-time updates just work without users having to write a workflow.


Hi @josh the last 3 days ago was very productive for me, but today the problem was back. It’s a very terrible issue, at this moment since the morning this problem doesn’t get away.

1 Like

Hey @josh :wave: I am still having this issue where the repeating group is not updating. I just sent in a bug report for you with a test page to show the issue. Hope it helps resolve the issue. Thanks!

Yeah, sorry, the band-aid we put in place stopped working this morning – we’re actively working on seeing if we can re-band-aid it


Should be working again now. That said, system is very close to its limits and could break again, so we’re actively working on more permanent fixes


hi @josh if you consider implement the idea of workflow force refresh the repeating group, maybe is more faster than other paliative solutions… at least it would give time to implement a definitive solution.

Best Regards,
R Lima.

Same here, it was back this morning quite severely.

@josh Thanks for the updates.

Thank you!

I’m not experiencing this exact issue, but I’m seeing a lot of strange behavior and 3-5 delays around repeating group updates today. Not sure if this could be a by-product of the most recent fix?

1 Like

This is happening extremely aggressively tonight in the middle of the night when it usually would not happen. Is this due to updates being pushed or something else?

I’m troubleshooting with a customer and their app is falling apart in front of us. They have to reload the page every time they make a change to anything. Absolutely debilitating.

Any updates? @josh