Rich Text Editor - hide toolbar

Is there a way to turn off the ribbon/toolbar in an event?
e.g. I initially want to just show the text, in read only mode, and only when “Edit” button is pressed do I want to show the toolbar and enable editting

1 Like

No but we can look into this. Please email support

1 Like

Was this addressed? I would definitely love this feature as it would make a blog much more feasible to build within Bubble.

1 Like

I’d need this too :slight_smile:


@dee, wipe the dust off Dave’s post and it might help you : )


Cool :slight_smile: thank you! :spider_web:

@mishav Thank you. That’s exactly what I need but there is also one issue you could probably help me with it. If I load default text from a dropdown menu (do a search for… contains…) it shows no text.

What are you trying to search? The rich text box? can you explain how you first load the default text, then step 2 etc. What custom states you use etc.

This might help understand where the problem lies.


  1. Selecting a value from the Dropdown on the very top loads text inside two RichtTextInputs as shown below

Settings of the Dropdown

In the RichtTextInput I do a search for Company with a constraint Dropdown’s value

Including the script to hide some Icons in the bar works fine without selecting a value from the Dropdown.

Problem: Neverthenless, as soon a value from the Dropdown is selected the hided Icons are shown again.

It must be the way the RTI control initialises itself after being loaded with data. I wouldn’t have thought that this was a control issue, but maybe the way bubble is pushing in the control.

Possibly a bug with bubble implementation. maybe need to reinitialise the control javascript again.

The alternative is to maybe use a custom state between the two, so the actual control never changes, only the the it is referencing is changed.

I have just had a look at this, adding the drop down, and using a custom state works fine until the customisation of the toolbar is added. I do not know what else to suggest. Maybe need to engage the help of @Bubble team to see what the limitation and work around it.

If I get more time if there is any other options/workarounds.

Has anyone been able to get the RichTextInput to work after applying the script? Seems as though it becomes disabled (user can no longer fill out) once the script is applied. Any help would be much appreciated.

Maybe try the bdk Text Editor? It has the option to hide toolbar among other things

Hi All, I think I found a workaround to solve this issue. I simply disabled all toolbar features to prevent any HTML from showing up in my final documents. I disabled all features that create HTML - including Bold, Italics, Underline, and Strikethrough. It’s a bit of a hack - but here’s what I did.

Step 1. Check the box to disable “Advanced Editing Features”. This gets rid of font, bullets, etc.

Step 2. Add a shape over top of Bold, Italics, etc. to hide them and kind of disable them from users.

Step 3: Make sure the color matches the toolbar snd the shape is brought to the front.

That’s it. Here’s the result: