Rich Text Element Issue

The rich text plugin seems to not be displaying initial content, nor accepting inputs. The content resets when something is pasted in, and when the enter key is pressed. Also, Initial content is not displaying

Anyone else having issues?

I have been replacing all mine because of this exact issue with ZQ RTE. It actually tripped me up Yesterday when I was working on a live page, that was weird. It was due to the RTE not showing default content. It also does not save any content in the RTE to a thing either. So pretty much a useless placeholder in its current state. It’s been a few weeks now. @bubble (Here is your bug report)

Yeah… I bought and downloaded that plugin. One tip that will get you through the interim - roll back the bubble RTE plugin update to version 2.0.2. it fixed this issue for me for now.

Oops, guess not fully. Still not saving to a thing

Thanks for the tip, even it it doesn’t save yet :wink:

Which RTE are you talking about? The Bubble one or the ZQ one?

1 Like

bubble Rich Text Editor

Haven’t had any issues with all my apps. Is this a new occurrence in existing apps? If so you should also file a bug report.

1 Like

Interesting… you’re not referring to the legacy plugin correct?
Yes, it’s being used in an existing app. Has worked fine until recently.

Nope, I always make it a point to keep my plugins up to date.

Do the issues happen on specific RTEs or throughout your app? Now that I think about it, i have had issues when switching over to Tooltip (which I haven’t filed a bug report now that I think about it). Are the RTEs with issues using Tooltip?

I have noticed another issue with the RTE not resetting it’s value (not what is visible in the text input itself) in the latest version. Reset action is working in 2.0.8.

@nickc I’ll file a bug report soon but maybe you can give the dev team a heads-up to do something about this. It’s confusing my users.

EDIT: Urgh. The reset action will only work properly if the initial content is not empty. Since I need parent content as initial content I’ve resorted to a conditional with [color=#000000][/color] (insert your default text #color) so the reset action works as intended.

Bubble informed me how to fix the issue!

  1. Enable auto binding
  2. Set up a privacy rule for the data type you are displaying/editing

HMU if you need help…

Hello everyone,

If you have any further inquiries about the Advanced Rich Text Editor Plugin, please don’t hesitate to contact us. Remember to mention our team when you do.

We suggest exploring the demo editor page and consulting the accompanying documentation for more information and assistance.

Warm regards,
Zeroqode Support Team.