Saving fields doesn't create a record

I have a form with manual input and some calculated values of those inputs. At the end I want to save that as a record. I realized I need to save individual fields. So I created workflow to define an event when “Submit” button is pressed:

  1. Created a new thing…
  2. Defined a new type…
  3. Set another field with… to use values from inputs that are actually used on the form
  4. Create new field and type
  5. Assign the values by … Insert a dynamic field

There are several types of fields that I try to save the information - mix of numbers, text, currency etc.

Issues I am facing:

  1. I tried looking in Database --> I don’t see any data record created.

  2. And how do I clear the form once the data is successfully saved?

  3. There is one type of field Currency $ on the form - but that type is not available when I try to create a new field.

  4. I also have a step two to redirect to the home page - that also is not happening.

  5. There is another button (“Clear”) to clear the form if user needs to start all over. Is there a pre-defined thing that I can use that will only clear the typed data on the form?

Sorry loaded questions here but there is something I may not be doing right. I followed the video of Apartment App sample on bubble.

1 Like

Anyone who can help? Bubble team??

You’re likely to get better feedback from the community if you share a link to the editor here, with the privacy permissions set to “Anyone can View.” At the very least, some screenshots will be helpful.

There are too many ways to build stuff in Bubble, so it’s almost impossible to debut specific situations without more information.

Sure, here is the link:

And here are the pictures:

  1. you have “only when user is logged in” on your action, so obviously nothing is created…
    if you want to keep that “only when” for your tests - add new user to your database then next to him you will see small link “run as”.
  2. next action in the same flow - reset inputs (element actions)
  3. you can keep numbers as numbers in the database, doesn’t matter if it’s currency or not

I am sorry can you pl. expand on 1 and 2? I tried my best but no luck.

  1. look at your picture’s bottom - “only when” is set. and you don’t have any user logged in so nothing is added.
  2. now look in the middle - where you have “create a new shopping cart…” after the arrow you can add next step. do it and on the list of actions choose Element actions - reset inputs

Ok I got the 2). But still not clear what do recommend for 1). I deleted the “only when” to keep things simple but not luck. What is typically needed it for it to work?

Anyone who can help? I got some help but still not able to save the form. Not sure what “Only when” action is required for it to work.

if you talk about this app: when Submit is clicked - data is added to the database. So what is your problem exactly, other than not spending a SINGLE minute on reading bubble’s documentation and/or doing some tutorials?

FYI… I have spent numerous hours reading looking at video but no luck. That’s why I have posted to this forum.

The problem is the data record is not saved when submit button is hit. I checked the Data tab and no where it shows the data (when a trial App is run using Preview) is saved. I expect that a table or a flat record is created. I am suspecting I am missing a key step just don’t know what it is. That’s why I provided access to this App editor.

are you serious?

Ok I see that now… have to figure out what’s changed?

BTW you don’t need to be disrespectful here. I very much appreciate the help but I hope you are respectful to a newbie.

The backend database view doesn’t update automatically. It takes some time for things to be visible in there.

Yep, I had to do multiple entries to actually verify what’s happening. After few minutes the entries show up. But when initially I ran into this issue DB was not populating at all. You can see am working on this since last 3 days.

Much appreciate your help.

I started with Bubble just few weeks ago (3, 4?) so this “newbie” thing doesn’t convince me at all, since I’m one myself :wink: And since I know HOW I started - I think anyone can. Read. The. Manual. First. :wink:

Sure and that’s a great thing you have accomplished a great deal.

May be its just me that I am slow or don’t have any dev background. The video shows something and it doesn’t work - the natural instinct is something is not right. And that will go away with more platform exposure and some confidence is built.

This is actually a very common question by new Users in my classes. It’s befuddling to them why their new data isn’t showing! And if it’s any consolation, I’ve been using Bubble for over a year and I still need to remind myself to flick over to another table and back to that table to display new data.

i would echo cowonthern here…its not obvious even after reading the docs that the DB does not refresh. I would say that @tjs did much more than is usual with many who post thier first question. @tjs clearly set-out the steps taken and the outcome of those steps, then posted a link to the editor. well done @tjs

1 Like

Thanks guys. The problem as I comprehend was 2 folds:

  • upon initial setup the data was not loading, so I was trying different things. One of which was setting a condition “when user log-in”. That complicated things

  • secondly, when you create the data fields, it won’t auto include all the fields. Just the basic ones like created on, created by, unique id etc… Then I realized I have to edit the table and manually check the fields I want to show on the data table. Not a big deal but anyone would expect that all your fields show up in the data table. Anyways, want to share in case someone like me can benefit.

Its all part of learning new things.