Select Query to MySql using SQL Database Connector plugin

I got stuck replacing the parameters in SQL Database Connector plugin. It’s connected to PlanetScale’s MySql The insert query below works, but the select query above doesn’t.

Looking at MySql query it seems like ? is the way to go, but it still doesn’t work even though there are old forums about it online.

What I’ve tried replacing the ? so far:

And many combinations of those.
The database column is in varchar(255) so Bubble text type should work fine.

The ? works fine for insert query below

@selection you are correct to use the “?” syntax for MySql. Are you able to “initialize” the query types? If so, then your syntax is good and you should look elsewhere for the problem.

hey there,
I’m sure about use, @recruiter
But try different type of test value, like what did you do for ‘recruiter’.
Do you get an error or empty data?

I’m able to initialize the query but the server always returns empty, when if hardcoded the “Test” value in, it would return a proper entry.

Also forgot to mentioned, the database column type is varchar(255)

@selection it’s something in your data or setup. Most servers allow you to see the logs of the query to see what is being sent. I would start there.

When you say “the server always returns empty”, is that from a workflow? The initialization of the query is only to map the data types. It won’t return any values. If you are calling the query from your app please post the call and the parameter you’re sending.

Here’s what the repeating group looks like

-My workflow is empty

This is what got returned (correctly) when hardcoded the recruiter name in.

This is what got returned when ? is replaced as variable.

Update: I’m fully suspecting a problem on PlanetScale side for this one.
I tried to view the complete log in PlanetScale by enabling the option to fully enclose my log, but the full log still hasn’t appeared for me.
No documentations or forum could exactly explain why that’s the case, why I posted some question on Planetscale’s forum (Which is pretty inactive).

At this point I’ll only keep this thread going if I got sth from the PlanetScale side.

Thanks for the answers :slight_smile: