SendGrid API defaulting to

Hi all - hoping some folks could help me out with setting up a sendgrid account. I’ve followed the instructions in this great post, including setting up a verified single sender and generating an API key. Unfortunately, when I click the ‘Verify sendgrid key’ button after pasting in the API key, I get the belowmessage. It looks like it’s defaulting to, which is not an e-mail I have access to (not on my bubble account, nor the verified sender for my sendgrid account. Is there a way to change the verification note to

There was an issue validating your key. Please check.

Tried to send a validation e-mail from admin@my

Error connecting to SendGrid: The from address does not match a verified Sender Identity. Mail cannot be sent until this error is resolved. Visit Sender Identity | Twilio to see the Sender Identity requirements


I’ve got the same problem, any tips on how to solve it?

Yes, this is pretty infuriating. This is the only solution I am aware of:


Thanks buddy!

1 Like

Thanks, both!

Hey there @afryer @matteo and @SerPounce,

It used to be a lot more simple with Bubble, but now doing something like sending an email is more complicated. :cry: Hopefully I can help you with this. :+1:

This error means that you just need to go through the verification process to verify your domain with SendGrid.

The best way is to verify it with the DNS settings. - Choose “Authenticate Your Domain”

Then choose your domain service and it will give you the DNS records to copy into your domain.

For google you would go to and click DNS from the menu on the left. Then you copy and past each one of the DNS records from SendGrid to your settings.

This authenticates your domain with SendGrid. Then you can change the “admin” part as well, once you are verified.


This is something new according to SendGrid: “The information on this page applies to Free Trial and Essentials customers who received access on or after April 6, 2020. If you received access before April 6, 2020, you can disregard the information below.”

If you need any more help setting this up you are more than welcome to book a session with me and we will get you set up @

Hope that helps! :blush:


Thanks man, solved :slight_smile:

1 Like

So glad that worked! :slight_smile: :raised_hands:

Sadly, I did this to a T and it did not work…I have GoDaddy and I am not sure whats happening. Seeing as once this is figured out it may be a quick 5 min fix. Can anyone provide a solution without having to book a session with NoCodeMinute for $100/hr?

Hey @moniquegowie,

I know not everyone can afford one-on-one sessions. I try to help out on here for free when I get a chance.

I would call GoDaddy’s tech support. I hear they have great support. They will probably be able to walk you through it for free. :blush:

I think it has something to do needing to remove part of the info you are putting in the DNS.

From what I hear you need to change it like this: For example, this would just be “em9979” instead of “

As an alternative, you can also do the second option to verify with an email address which might be easier.

I hope that helps! :blush:


Hello, not the affordability, I just didn’t want to spend that amount for a quick fix. The account was verified on send-grid, but on bubble the side I still get that error when inputting the API key. I noticed that the error was giving me a old domain that is not the new domain that has been connected to the app. Could that be a reason, maybe a caching issue with Bubble?

I’m thinking maybe something with Bubble, yeah. If there is no way to change it, then maybe send Bubble a bug report. If it’s the old domain and there is no way to refresh it, maybe they have a way to fix it. I would contact Bubble, for sure, to see if they can help with it. :+1:

This topic was automatically closed after 70 days. New replies are no longer allowed.