Forum Academy Marketplace Showcase Pricing Features

Sendgrid API Not Working

I’m trying to set up the Sendgrid plugin by @copilot. I’ve added my API key to the “API Key” field on the installed plugins page. However, when I try to add “Sendgrid - Send Email” to a workflow and add Substitution Tags, the editor prompts me to enter my API Key (“Enter your API Key” button) and directs me to the page where I’ve already entered my key. When I run the workflow, the email does not send, nor do I receive an error message or any indication that an email was attempted to be sent.

I’m fairly new to all of this, so I am likely just missing something basic. Do I need to “save” the key somehow so it stops prompting me? Do I need to wait a few days? Do I need to enter it somewhere else? Thanks!

Hey @hellodwelling!

Though we’re confident this isn’t a bug, the best path forward is by submitting a bug report. :slight_smile:

Hey @copilot,

I have a similar situation and not sure if it’s a bug or not. Submitted a bug report last week, but haven’t received a reply. Hope you can help here.

This has happened in several different apps with correct API keys. I can say they’re correct as API calls worked in Postman. Here’s a couple of error messages the plugin raised:


Could you please help solving these issues? Let me know if you need any extra info.

Thanks,
Andrey

Here’s the second error’s text for convenience:

Workflow error - Plugin action SendGrid - Send email error: TypeError: Cannot read property ‘forEach’ of undefined at eval (eval at build_function (/var/task/index.js:55:21), :3:102) at /var/task/index.js:278:23 at run_fn (/var/task/u.js:594:18)

1 Like

Hi @andrey_li,

We try our best to diagnose through a filed bug report. As you can imagine, we also rely on our SendGrid plugin which issues tons of emails everyday. Consequently, we’re also one of the first to know when something is wrong. In any case, happy to investigate once we dig through. :slight_smile:

@copilot, thanks! I’m also pretty sure it’s just user error :slight_smile:, and hoping it’s a simple fix. I submitted a request through the bug tracker. Appreciate the help!

Thanks @copilot. Watching this issue. To confirm, do you see the bug report @andrey_li filed or do you need a new one to be submitted?

Hi @copilot, I hope you’re well. Have you been able to determine what may be causing this at all?

Hi @copilot,

Is there any chance you could assist with solving this issue? It’s a blocker at the moment and I was hoping I wouldn’t need to replicate and debug the plugin or make direct API calls. The strangest thing is the plugin worked alright but at one moment just stopped. Could it be Bubble engine upgrade?

Thank you!

@copilot, can this be the source of the problem: https://sendgrid.com/docs/for-developers/sending-email/sender-identity/?

Hi @andrey_li,

We’re on our way to upgrading the underlying API for the SendGrid plugin. No ETA at this time but we’re fairly close to some new pushes! :slight_smile:

1 Like

Any update…also having issues

Any updates?

Facing the same issue as @andrey_li

Thanks in advance.

Jay
India

same issues. Anyone figured it out?

Hi @copilot , guess it’s the same issue others encounter, my API key works just fine for the Bubble implementation of sendgrid (templates included), but I can’t get your plugin to work, I don’t get any error but no email would send.

Anything I might be doing wrong ? Should be very straightforward.

Hey @Tomdez1989,

File a bug report with us over at https://withcopilot.com/contact. :+1:

I had the same error, but I got my plugin working in the end. Turns out I forgot to put in the API into the plugin page. Once I added it in, the issue went away.

Hey @copilot,

Could you look for my bug report I posted in May this year? Do you think it might be the same issue @Tomdez1989 and others encounter? Hopefully you’ve gathered enough information in the past half a year to finally get to the bottom of this nasty bug so many people have been struggling with.

Thanks in advance!

For some reason I doubt everyone who’s been experiencing this forgot to include their API key. You got lucky, congrats!

1 Like

Hey @andrey_li,

We’ve received a number of reports of applications being unable to reach their customers’ inboxes since Q2 of this year. In most of the reported cases, the root cause was tied to Sender Identity including the Single Sender Verification process.

As you can imagine, thousands of applications utilize the SendGrid plugin (including ours!) so the inability to send emails at a global scope would be a serious matter for us. Either way, we’ll give you a shout directly to make sure your concerns are addressed! :slight_smile: