Setting up domain and email-godaddy

I’m trying to set up my bubble app with godaddy, but it appears I’m doing something wrong. Here’s what I am getting from Bubble:

And here is what it looks like in godaddy.

What am I doing wrong?


Remove A name with IP address.

You cannot add @ CNAME I think, as in GoDaddy does not do bare domains.

What you need is just www CNAME.

Then create a forwarding if possible from bare domain to www as 301 permanent redirect.

This should also allow you to still use your email MX records.


Thanks for your help, but I don’t understand what you’re saying.

A @ (what goes here) 1/2 Hour
CNAME www (what goes here) 1 Hour

Thanks again,

1 Like

In the first screenshot you have two settings

ALIAS/ANAME Name: (Blank) value:


CNAME Name: www value:

Making sure you have entered your domain in the Bubble panel as, also making sure you have included “www”

Then go onto GoDaddy, here you can only add CNAME record as displayed by Bubble.

But separate from this, you also currently have an A Record, assuming this is pointing to a bubble server, you have then yet to completely transfer to CloudFlare.

So if this is Bubble, I would delete the A record.

Also you will need to create a normal forwarding from to

These are generally the issues I have come across and solved this way with 123-reg and Google Domains. Maybe others have solved it differently for GoDaddy.


Please take a look at our YouTube tutorials for setting up your domain; the “Transferring nameservers” tutorial has been particularly useful for our GoDaddy users.


Hello Eve,

Thank you for helping out.

Just to clarify for my info, I understand moving nameservers is the suggested route for bare domains.

But does the solution I have mentioned have any negative implications. It would be good to know, makes sure I understand any downsides.

The solution you mentioned is not quite as stable as moving nameservers, but it’s certainly a valid fix here.

1 Like

This topic was automatically closed after 70 days. New replies are no longer allowed.