Forum Academy Marketplace Showcase Pricing Features

Sharing to Social Platforms (Facebook & Twitter)

I have looked at many forum post and could not get my problem fixed. I have a article page that i am trying to share. But i have SEO set up correctly as i have seen from other forum post.
image
But still when sharing to both Facebook and twitter they don’t show the social cards.

I have also tried the Twitter Card Validator and it says for the articles
“ERROR: Fetching the page failed because it’s denied by robots.txt.”
image

Not sure how to fix this.
I will note that the home page URL (index page) does work. Also the page that i am trying to share isnt published yet so it is a “version-test” URL, not sure if this makes a difference.

Hey @1david2hot :wave:

There are a few different factors that could be going into this. Have you interacted with the SEO section of your app settings yet? It might be worth clicking through there to make sure everything is filled in and set correctly.

Past that, keep in mind that if you’re setting page titles and descriptions dynamically, Privacy rules become a factor. You might take a moment to review those for the involved data types.

Finally, have you registered as a Google webmaster to get a deeper level of visibility into what Google is seeing as it interacts with your site?

Ultimately, if you continue to run into issues with this, don’t hesitate to reach out to us directly at [email protected] and we can take a closer look at what might be going on.

1 Like

So if i type in the basic domain name it works, but when its a “post” URL it cant seem to work. I have setup SEO settings for the page and the app. Also the privacy settings seem to be alright.

Also, not sure about this. Will this not work if the page is not yet published? Like i am trying everything in the development mode, so the URL has “version-test” in it and i am on a paid plan. So SEO works.

@1david2hot Yea, your privacy rule looks fine.

Honestly, I’m inclined to recommend deploying and giving some time for the page and it’s content to be indexed. If you haven’t already, create a webmaster account and make sure Google’s aware of the page.

These things can take some time but if after deploying you continue to run into issues, shoot us an email with your app / page details and we can take a closer look. Best way to reach us is [email protected]

1 Like

Thank you i will look into Webmaster!

So i am getting an error from webmaster, the error is “blocked by robots.txt.” So my guess is that when i launch the page i wont have these errors anymore.

Yep! deploy and give it a test. Keep in mind that it can take some time for things to get indexed correctly. But, I bet you’ll find it works as expected in live.

If you end up with any additional questions, email us at [email protected]

1 Like