Slack oauth2 in bubble

I try to connect slack oauth2 using the following:

however, it tells me “error: not_authed”. I only have bot tokens permissions and the token I enter after bearer is the “Bot User OAuth Token”.

do you have any idea what I might be doing wrong?

thanks

Here’s my setting :wink:
You need to have the correct scopes set in Slack (and you can have more than the 3 I have that is really just for user auth)

@Jici I try this and I keep getting this error:



not sure what to do. can you think of a reason why this happens? I googled but not much to be found.

Remove the access token in header key. Look at my screenshot.

@Jici Removed it and still the same result.

You are mixing Bot scopes and user scopes
you first need to request user scope and after, you will be able to make another request for both scope (but using a manual process for this one and storing the bot auth in DB). Sadly, Slack doesn’t allow to request bot and user scope at the same time and also doesn’t return the open ID data if you request bot scope only (there’s a way to request both scopes, but the issue will remain as you cannot get the profile endpoint if you request both at the same time)

I was thinking you only need to authenticate user at first.

@Jici Still happening even after I added user token scopes


Which url redirect did you set in slack? Is it a different error now?

@Jici The error is still the same. I set many url redirects including the one in the bubble app. I also created an oauth_redirect page just in case, but it does not work either.

No issue on my side. Not sure what is wrong with your settings. Do you get to the authorize page or the error come before that?

@Jici No, I dont get to the authorize page. I am redirected immediately to “theres been a hitch”. Yeah, pretty weird.

Delete dev key/secret, make sure you are using the correct client ID and client secret in “live” fields (this will be applied to dev too). Can you share the url after that (where you get the error)

@Jici You are right, I had entered the App id in the “app id” field; I now entered the “client id” and it worked. the naming tricked me. thanks.

1 Like