Forum Academy Marketplace Showcase Pricing Features

[Solved] Auto-binding for a Drop-down doesn't show the field I want to modify

Hi everybody,

First post here. I’m new to bubble, but until now I’ve been able to find my way around everything I needed. But now I’ve hit an obstacle and it seems the topic has been posted here a couple of times without a solution:

Trouble Autobinding dropdown field (explanation with video)
Drop down dynamic choices can't select field to auto bind

To summarise the problem and clarify a few things:
I want to allow my user to edit a field by modifying a Data point that is fed with a Drop-down (made of an Option Set) with auto-binding. However, the “Field to modify” only shows the option to create a new field, instead of showing me the fields of the Data Type I want to modify. When I choose that option and create a new field, I can see it showing up in that Data Type, but my objective is to modify an existing one instead of creating a new one.

Thank you in advance for your responses :slight_smile:

Could you post screenshots of your data types and your dropdown configuration?

My hunches would be:

  1. Privacy rules (but I guess you already covered that since you linked to a thread with that same issue.)

  2. Does the User data actually have the right field?

  3. Wrong input type? Are you using multi select dropdown?
    In the video you linked to, I see the person with the question seems to be using the multi-select dropdown. The multi-select dropdown gives you a list of stuff. Even if you select maximum number of items is 1, you still get a list. You could the user’s data type to accept a list of things instead of just 1 thing that that should autobind properly.

Hi Rico,

Thank you for your comment. Here are the screenshots:
Data types:


Dropdown config:
(Please don’t mind the alert below “Field to modify”. It appeared after I created a new field to test where it went – As said in the post, it did go to the correct place [the Data Type from the screenshot], but it created a new Type instead of modifying the field.)

  1. Privacy rules is covered indeed.
  2. The Data Type (in my case it’s not the “User” Data Type) does have the right field (“Tipo”).
  3. I’m not using multi select dropdown in my case.

I hope this info is enough, otherwise let me know and I’ll try to answer ASAP :slight_smile:

Check the rules again maybe? Seems like that messaging is calling for you

I think it’s a type mismatch - if I understood it correctly.

You can associate a option set to a Data Type. So, in your Pedido data type:

  1. create a new field
  2. scroll down and select the option set tipos de producto

Option sets make life sooo much easier.

2 Likes

You’re a boss, Rico! Completely solved this issue, but I stumbled upon a different one:

I have an “Other” option in the dropdown that activates an input when clicked. Now I cannot find a way to replace the “Other” option with the input text. I assume it’s because now those two are different types (Option Set; text). Is there a way to solve it?

PS.: For people struggling with the problem, note that you have to change the inputs again everywhere you’ve referenced that field.

Thanks, I’ll tell @NigelG you said I’m the real Bubble boss. :wink:

The “other” option will require rethinking your entire approach.

If I recall correctly, “other” option allows the user to add a new item. That won’t work because the source of your data is an option set. Option sets can’t be modified via workflow. So you would have to move away from option sets back into actual database types.

1 Like

I see, thank you again!