Forum Academy Marketplace Showcase Pricing Features

[Solved] Blank field, but Initial Content is set

The issue I cant solve seems similar to solved here, but not.
What’s going on. The User fills in the data about his Education.
That are correctly stored in the database (as CV thing). I see it, so saving data to appropriate fields is ok.

Now I want that when the user returns to the Education section, the previously saved data is displayed there. For example, to display the name of the school, I set Initial content as Parent’sgroup CV’s School.

However, after filling in and saving the data, Bubble considers this field empty.

Why?

This already works for the User’s general info tab, but everything is easily output to the fields via the Current User’s<…>.

The difference btw General info and Education tabs is

  • data types: User and CV
  • different tabs of TabElement I use to make sections on the same page (not to multiply pages). Education tab(group) data type is CV, General info tab data type is User.
  • Page data type, where all tabs are, is also a User, but this does not prevent me from displaying matches on other tabs (for example, to display matches with vacancies that are also of another data type (thing Job).

I can solve this by relocation all the fields about Education directly to the User.
But then the User will be overloaded with fields, and a separately created thing CV does not make sence.
It seems wrong for future application features. I should leave 3 types of things: User, CV and Job.

Hi there, @prpse.connect… the first question that comes to mind for me is how are you setting the data source of the parent group that is being referenced? In other words, if you aren’t specifying which thing in the CV data type you are trying to show the data for, then the initial content won’t evaluate to a value, and the input’s placeholder will be shown instead. So, are you sure the Parent group's CV is being set?

Best…
Mike

Here is the screen record Loom | Free Screen & Video Recording Software. I dont see what I did wrong.

Now Type of content of parents group is set as CV. If i set/change Data source for (parent’s group)EduContent - field School stays blank.

As far as I can see from your video and comments, you have done it correctly. I think this is a long shot but try adding a new form field in case there is a bug or something with your currently one.

If I am seeing the video correctly, it’s exactly what I suspected. The parent group (which looks like it is called 4.EDU content) doesn’t have a data source, and you don’t appear to be sending any data to that group as part of a workflow. If you are trying to show the data for the CV you are creating in step 1 of the workflow, try adding a second step to the workflow that displays the results of step 1 in the 4.EDU content group.

well, there is a progress, but for the other page.

I did that and now School’s name displays on Edit CV page. But once I go previous page (refresh) - its empty.
Looks like smth wrong with Create CV workflow - when the page is refreshed, the fields are cleared.
Setting DataSource for Edu Content group in its properties editor (for Current group CV, or Edu Content CV, or leave it empty) does not change this behavior.

You have fields that are in a group… every time you access that page, you have to tell the group what to display. What you did based on my last response only told the group what to display when that exact workflow is run.

So what finally worked:

  1. Create the field Education for User with the type CV

  2. Workflow: When Button create clicked >Create new thing CV>Make changes to a Current user as Education= Result of the prev.Step
    image

  3. Then, to display Education on the respective tab - set as Initial content for inputs Current user Education <…>

1 Like

EduContent group Data source - remains Blank.

EduContent group Data source - remains Blank.

Well, sure, and it doesn’t matter that it’s blank because you solved the problem a different way, and you are no longer referring to the parent group in the initial content. Anyway, glad you got it sorted out!

This topic was automatically closed after 70 days. New replies are no longer allowed.