Sorry you can't modify this

Hey everyone!

I have a form, in which every field is set to autobind its respective field in the database. In privacy settings, I’ve enabled auto binding only when current user is logged in. I have registered one account only for form filling.

When some random user opens the form, I’m logging into that created account in a page load workflow. I can see that the user is getting logged in, but the issue is that it is not letting me change the values of fields and throwing me this “Sorry you can’t modify this” error.

Any help would be much appreciated. Thank you

This is certainly odd behaviour. Can you post a screenshot of your privacy settings?

Here are the privacy rules :

Here is the Workflow where I’m logging the user in:

Here is the error:

Thanks for your help

Are you binding something in that form to a different type? Or is there only one possible data type?

All the form data is being stored in a single data type, “Application”

And also, I see user is being logged out on page reload in preview mode even when I selected “yes” for “stay logged in”

Do you think that has anything to do with that error?

Just as a test, have you tried logging the user in, then refreshing the page, then seeing if the autobinding works?

Yahh still the same

Something is logging the user out and is definitely contributing to the error.

This topic was automatically closed after 70 days. New replies are no longer allowed.