Forum Documentation Showcase Pricing Learn more

Sorting applies only the first rule!

I’m trying to sort a simple list where the “type of thing” is generated from an SQL query. See the action below:

The sorting works fine with the “Status”, but the “Seconds” is completely ignored. When I tried swapping the rules, the sorting was applied on “Seconds” and “Status” was ignored.

Both field are numbers.

I tried so many things/combinations that I think this is just a bug…

Can you send a screenshot of the data in the RG ? (running)

The data isn’t displayed in the RG directly. Here’s my setup:

  1. I set a custom state to the result of the SQL query (list)
  2. Apply the sorting to the custom state (screenshot above)
  3. A “List of Numbers” length is set to the number of elements in the previous custom state
  4. The RG is of type Number and has the “List of Numbers” value as source
  5. I display the items in the RG with : Custom State :item # Current cell's index

Hum. May be hard to help without seeing data after filtering :confused:
I think that posting a support ticket is the best option for you