Stop scrolling at the end of a group - help please

I have a page built in the spirit of a single page app. It is a page with three groups which are made visible depending on an option a user clicks. Only one group is visible at any time.

The root of the issue is that each group is a different length so the page length is as long as the longest group. The problem is when viewing a shorter group. Because the user is scrolling the page, they can scroll down into white space.

Is there a way to stop the scrolling so that it obeys the group length instead of the page length?


:wave: Hey there!

I do go through this in my members only portal. Check it out: One-page App

Basically you need to stack the groups on top of each other like legos and make sure they are collapsed if hidden. Then it gets rid of the empty space at the bottom.

Want to learn more?


Hope that helps! :blush:

Hi @socialrepublic, As @J805 mentions, you can stack your groups, and use the option “collapse element’s height when hidden” to hide the excess white space. Just be sure the longest group fills to the bottom

1 Like

Ah-ha! Brilliant. Thanks so much! @Zaque and @j805

Hi, I am still tryin to do it but I haven’t had success… would you mind to share a loom video or share the editor?

Thanks a lot

Here’s the basic setup attached (assuming your hiding rules are all setup). When the selected (longest group) is hidden, the page length will be shortened

@vinicius.tst.eng, hope that helps, but let me know if you’re still stuck

1 Like
1 Like

This topic was automatically closed after 70 days. New replies are no longer allowed.