Strange Stripe error message

One of my users could not use Stripe checkout on my website and received the following strange error message:

Stripe error: Search is not supported on api version 2020-03-02. Update your API version, or set the API Version of this request to 2020-08-27 or greater.

I have never seen this before.

Does anyone know what the issue is and how I can resolve it?

Any help would be appreciated!

1 Like

The error says it all. Go to plugin page, find stripe and check the version dropdown and if possible choose a newer version there.

Hi.

Stripe plugin is on the most updated version (V3) so can’t be that.

Then, that’s interesting. I did some search and could find out that the search requires you send another header info (Search | Stripe Documentation):

Of course, if you are using stripe directly from the plugin and in workflows, I don’t know if there is a place to send API version along with the request. What workflow action do you get this error? Do you know?

@jddmrgn

Is this is a non-Bubble Stripe plugin?

It is very odd.

I am simply using the ‘charge a user’ workflow action.

It has always worked correctly and perfectly, but that particular user encountered that strange error message.

No, its the Bubble Stripe plugin. Updated to V3.

Bubble has what I have seen referred to as a “deep integration” with Stripe. This is what allows the “current user” to display Stripe API information when calling it within expressions.

If a “document certification” failed for a particular user (shown as part of the error message in your post) … this may be about something wrong for that user within this custom implementation (meaning … the Bubble/Stripe native integration).

Definitely an instance to contact Bubble Support on.

If you decide to contact them, please do share with us what you find out. :slight_smile:

Thanks for the info!

I have contacted Bubble and Stripe to query this so I will let you know what they say!

It is now affecting other users too, reporting same
issue…

Screen Shot 2024-02-12 at 8.08.28 PM

I’m getting the same error here! My stripe plug in is also up to date (v3). I have submitted the issue to Stripe but I haven’t heard back from them yet

1 Like

Found the solution guys.

Go to your Stripe developer account.

Scroll to bottom where it says versions.

You’ll see a button saying Upgrade available….

Update.

Sorted.

5 Likes

Thank you!! This made my day!

1 Like

No worries, needed to be sorted!

I had the same issue and that fixed it. Thank youuuuuu!

Did Stripe give anyone a heads up first? Also, what happens if I don’t have a developer account. I received the same message from a client as they were trying to make payment. Embarrassing.

No heads up from Stripe but it’s likely because it’s an integration issue and not directly a product issue. I would suggest requesting access to the developer account if you don’t already have access. It’s a quick fix once you upgrade / update.

@jddmrgn thank you this.

Thank you!