Stripe trigger checkout.session.completed Trigger failed: You cannot use `line_items.amount`

Hello - I am stuck trying to test the webhook for checkout.session.completed
I’ve tried many variations and keep running into this message:
Trigger failed: You cannot use line_items.amount, line_items.currency,, line_items.description, or line_items.images in this API version. Please use line_items.price or line_items.price_data. Please see Checkout prices migration guide | Stripe Documentation for more information.

Any specific tips or things to look towards for a fix? It seems like Stripe updated how this works and I’m wondering if some of the training / forum posts I’ve seen are outdated.

I’m guessing you’re using those outdated parameters in your Create Checkout Session call…

As the error message says, those parameters are no longer used, so you’ll need to adjust your Create Checkout Session call to use the new parameters…

Check the APi docs for how to create a checkout session using the latest API version…

Stripe API Reference - Create a Session

1 Like

I have read and re-read the API guides and still no luck. It’s not clear to me how to change the format. Plus, when I make some changes I get error messages about header name. Then I remove header and check all boxes Queryst. and get another error message.
I’ve tried numerous variations of adding line_items.price in as a parameter or into the body as a JSON object.

Well, I don’t know what you’re doing regarding any of those things, so it’s a bit difficult to help…

Free free to share some screenshots of your API call setup if you want someone to be able to give any specific guidance on this…

Thanks for your offer. Here’s my layout:

The value in Body parameters is:

I’ve tried various ways of putting line_items.price & into both the Parameters and Body Parameters based on what is in the Stripe API.

Because the error message says "you cannot use “line_items.amount”, and I feel like I had tried so many other things, I tried choosing “Ignore Field” in the returned values for “amount” but admittedly I was just grasping…

I am having a similar issue, wondering if there was any fix or workaround you found?

fixed this issue by triggering the webhook using stripes CLI downloaded onto my computer (didn’t work with the online version) with Homebrew. I triggered it with “stripe trigger checkout.session.completed” in the command line and bubble picked it up all good!
I followed this Get started with the Stripe CLI | Stripe Documentation

having trouble triggering account.application.authorized and account.external_account.updated
will report back if i find a fix for these, as it shows the error “this event … is not supported by the Stripe CLI”