↔ Swiper Effects - New Plugin from Zeroqode

Swiper is the most modern free mobile touch slider with hardware accelerated transitions and amazing native behavior. It is intended to be used in mobile websites, mobile web apps, and mobile native/hybrid apps. The plugin has 5 effects, different pagination types, autoplay mode, and many other features.

Swiper_efects

Live demo: https://zeroqode-demo-28.bubbleapps.io/swiper_effects

DEMO & DOCUMENTATION

Swiper Effects | Plugin for Bubble by Zeroqode

SUPERCHARGE YOUR APP WITH ZEROQODE PLUGINS

No-Code App Plugins for Bubble | Zeroqode

Levon Terteryan
Founder @ Zeroqode
#1 Bubble Publisher and Developer

logo-icon-S-circle

:file_folder: 130+ Bubble Templates
:mortar_board: 25+ Bubble Courses
:gear: 300+ Bubble Plugins
:iphone: Convert Bubble app to iOS & Android
:man_technologist:t4: No-code Development Services

4 Likes

Hi there :wave:

@ZeroqodeSupport I just purchased this plugin for $20, thinking it would save me a lot of time and headache trying to implement something similar. I thoroughly went through your demo and what documentation and forum posts were available before actually buying. That said, now that I have it installed, I have a couple of big problems that I’m hoping you can help me solve.

First, it seems like the plugin is overriding the responsive settings of my repeating group. I have it set currently to a minimum column width of 100 percent, because I don’t want any part of the next cell showing. Mysteriously, once I’ve applied the swiper to this repeating group, the column no longer takes up the full width of the RG, but rather the edge of the next cell is visible. This is not at all intuitive, nor is it advertised on the plugin page. Is there a way to overcome this?

Second, and more concerning, I find the “autoplay” feature quite confusing. When I leave the box unchecked, I find that it autoplays (which would be the opposite of the expected behavior). When I check the box, it no longer autoplays on desktop. However, it then autoplays rapidly on mobile.

As is, I find the plugin to be totally unusable. Hoping you can help me understand if there is something I’m doing wrong or, if not, offer me a refund.

Thank you!

Quick update here: The more I dig into this plugin, the more problems I’m finding. Just attempted to use the “fade” effect but find that it results in weird overlapping behavior with text elements from one cell to the next?

Hello @ts11

Thanks for reaching out.

May you provide an example of how the plugin is overriding the settings of your repeating group? If possible, also show the settings of your repeating group and how you are using the plugin to implement your use case.

Regarding. the autoplay feature, we will definitely check this issue and see what might have gone wrong. As for the issue with the “fade” effect, does the text overlap only when selecting the fade effect? Please provide a bit more details on your setup(plugin element settings, repeating group layout), this information can help us to investigate your case and replicate the mentioned issues on our end.

Looking forward to your reply.

Regards,
Zeroqode Support Team

Hi Zeroqode,
I am following your setup from your editor, not able to get this to work. Maybe a step by step video perhaps?

Hello @abdul

Thanks for reaching out.

Would you mind sharing your setup and what are exactly are you struggling with? Please share the screenshots or the video recording and we’ll be happy to assist.

Looking forward to your reply.

Regards,
Zeroqode Support Team

Sure. Here is a video from my setup from my editor: Watch - Screencastify

Thanks for the video recording @abdul

To set up the swiper effects in the same way as our demo page, please do the following:

  1. Place a group element on the page and the plugin element(swiper) on the page, the plugin element acts as a connector between the group and the plugin.
  2. Place a repeating group on top of it, with the desired data source, in our case its: 's imageslide1: Screenshot by Lightshot
  3. Put a group inside of the repeating group, select the Current cell’s ImageSlide, for the data source and image background: Screenshot by Lightshot
  4. Match the IDs of the repeating group and the plugin element, in our case it: rg1 Screenshot by Lightshot, Screenshot by Lightshot.
  5. Also, have some images saved up in the database to be shown on the page: Screenshot by Lightshot

Hopefully, it helps you solve the issue with the setup :slight_smile:

In case you have any other questions, just let us know.

Regards,
Zeroqode Support Team

Thanks for the reply @ZeroqodeSupport . Still no success. Looks like i have the same setup as you provided: Screencastify

Thanks for more details @abdul

Due to the fact that we have some additional questions regarding your settings, can you please add our Support Team email to the list of collaborators to your application and provide me a link to your application? This will allow us to check your settings and run some tests to fix the mentioned problem.

To add our Support Team as a collaborator, you need to do the following steps in the Bubble Editor:

Settings > Collaboration > Add email support@zeroqode.com

Note: avoid the warning message regarding the plan, as we are an agency and you can easily add us to your collaborators.

Looking to hearing from you soon.

Regards,
Zeroqode Support Team

Thanks, just sent an invite. I created a “Test” page so the issue isolated.

Unfortunately, we can’t seem to access your app, as it looks like the access has been revoked @abdul. Would you mind adding us again and providing a link to your app?

Hi Team,
I just removed and added you back. Not sure why it’s not letting you access.

We’ve checked your app and found a couple of issues that might be affecting how the plugin works.

  1. The app is not updated and has 46 errors on the page, this makes the app difficult to navigate and certain groups do not have a data source that might affect the work of the plugin.

  2. The type of content for RG and the group should be Image if you are trying to display images.


  3. Swiper element plugin ID should match only with the Repeating group ID, there can’t be multiple groups having the same ID. Please remove the “swipe” ID name from other groups (leave the ID only for the plugin and RG).

Please make these changes, and let us know the result.

Regards,
Zeroqode Support Team

Hi Team,
Hi Team,

Thanks for your email. I adjusted to your suggestions. Still not getting it to work. I noticed that I am getting an error stating that “swiper effects” is not installed. Please see attached.


Hi Team,
I replaced the swiper element on page to clear that error I was getting. Still not getting it to swipe on mobile.

Currently, you do not have any images that could be swiped, also from your set up you are not doing a Search for images, therefore it does not show any data, and there are lots of repeating groups on top of each other.

  1. Please create a datatype, with an image field, and add couple of images there.


  2. Remove unnecessary groups/repeating groups from the place where you would like the swiper to work. Only have one repeating group, and one regular group. For the repeating group, set data source, Search for Image slides(or whatever you called it), type of content should be the same as the data source. RG settings: Screenshot by Lightshot, Inside Group settings: Screenshot by Lightshot. Please replicate these two groups in the exact way.

  3. Place the swiper element on the page(visible). Match the ID of RG, with ID you put in the swiper element, do not have any other ID’s in the other elements. Swiper element ID: Screenshot by Lightshot, RG element ID: Screenshot by Lightshot.

Please have these elements only.

Looking forward to your reply.

Regards,
Zeroqode Support Team

Hi Team,
I do have images coming from a data source from it’s parent.
Yes I do have other groups, that show other media, which is shown conditionally.
I do have buttons which I am able to cycle through the images but not swipe through.

Hi @abdul,
Thank you for your message and sorry for the late reply due to the weekend.

We did carefully look into your app and besides the fact that you have three Swipe Plugins installed there is none of the plugin elements on the index page and any workflow set up that would use the plugin events and actions.


Can you please provide short step-by-step instructions that will help us look into the reported issue?
As well we tried to sign-up with a new account but unfortunately, the sign-up button is disabled and does nothing.

Please review the app and let us know where to look for the issue.

Thank you and have a great day!
Regards,
Zeroqode Support Team.

Hi Team,
I made a test page for you as I referred to in a previous response. Looks like you are looking at a different page. Your swipe element in a group. Does an additional element need to be added to the page in order for it to work?

1 Like