Forum Academy Marketplace Showcase Pricing Features

Terminating Animations

Hello everyone! I have written out an animation for my homepage load screen. Essentially, a few elements appear in sequence with pauses between them. I have tried to add a “skip” button to allow users to get straight to the site. However, it seems that there is no way to terminate animations. I placed “terminate this workflow” actions all over the place in an effort to stop the workflow before and after each of the “pause” actions. It still runs the animations no matter what I do. I have even tried to move the workflow from the “On Page Load” event to “Custom Events” but it didn’t make a difference. No matter what I do or what condition I place on the animations, they WILL run. Here is the workflow without the “Terminate” actions:

Has anyone ever managed to terminate workflows with animations based on a custom state? I’m still struggling with this issue :frowning:

I have broken up the animation into steps, with a “terminate this workflow” at the start of each step that will run only when the skip button’s state “clicked” is set to “yes”. I then try to set the state to “yes” with the button, but these workflows continue to run!

On page load, trigger the 5 animations in sequence via custom events:

Animation 1:

Animation 2:

Animation 3:



Animation 4:

Animation 5:

Example of “terminate workflow” condition set at the beginning of each animation event.

Skip Button Setting the clicked state to “yes”

Interesting challenge. Could it have something to do with the order of operations? Meaning, the animations are started, you click the skip button, but that doesn’t matter because the animations are already go-for-launch.

This is what I was thinking but there is no indication that animations are treated differently regarding order of operations. For example, I am successfully managing to trigger a “Show” action on one of the elements that are animated, which means that the workflow to set “Button Clicked” to yes IS happening in the middle of the animations… BUT, the animations just continue to happen anyway.

Order of operations doesn’t really make any difference…Bubble will trigger the actions in order but they are run sequentially…and just because it is triggered before another action, doesn’t mean it is ‘executed’ before the next action is triggered…so if action 1 takes 3 seconds to complete you could very well have actions 2, 3 and 4 triggered and executing at the same time.

Put a pause in front of the terminate action and see if that works.

If it doesn’t test things out and build up. To start that process see if a simple action of terminate workflow works with only a single custom event instead of the entire sequence…also test if it works with debug_mode off (remove from URL debug_mode parameter).

Also, what is your ultimate goal…if you can demonstrate with an example video or something, there may very well be a more efficient way to accomplish it.

Hi!

Here is a test example:

My Page (bubbleapps.io)

I am not sure how to share the editor… never done that before but will add the link once I figure it out.

EDIT: Here is the editor

Messagetest123456789 | Bubble Editor

To answer your question, the goal is to terminate the animation workflow and just show all of the elements. It’s essentially a “Skip” button for those who don’t want to watch the intro animation for the homepage.

One idea would be to put a breakpoint at this action.

I’ve got a hunch that whenever you press the button, it actually adds that action to the back of the line. The line at this point consists of all workflows and actions triggered on the Page is loaded workflow.

What might solve it is to have each workflow trigger the next workflow - instead of the Page is loaded trigger all of them. My hunch is that in this manner the set state action will actually happen in between the animations.

It might be helpful - visually - to have the clicked stated shown somewhere on the page at all times. It might help you in troubleshooting this.

I tried the waterfall method of each custom event triggering the next but it didn’t change anything. I will change it in the editor and see if the breakpoint helps too! thank you !

Yep, I think it gets added to the back of the line.

If you turn off debug mode it’ll actually run the button’s work flow but it will continue to run the previous workflow.

This topic was automatically closed after 14 days. New replies are no longer allowed.