Unable to Update repeating group after running a MySQL query for a table

Hi @davidb2 @mishav

I have connected my app with “SQL Connector” plugin and I am fetching few records from MySQL to a RG and performing CRUD (Create, Read, Update and Delete) operations.

After I run a query (say creating new record using INSERT query ), I am not seeing fresh data until I refresh my browser.

Is there any work around for this ?

I got stuck with my app at this point. Can you please help me with this ?

Any input is appreciated.


Hi @sam2

The issue of updating without page refresh came to me with a plugin. I handled this with the send more parameter to the page. I hope it will help you.

Send parameters to the current page, Go to page action allows you to make changes without refreshing the page. Basically, I set up my order according to this.

Of course, you choose a suitable trigger for the first step.

When a button clicked> Display list to RG> Go to page (send parameter)

I have given a url parameter to the current page eg. clearlist - yes

As the last step
When Page is Loaded Get clearlist from page URL is yes> Go to Previous Page

And the data is refreshed without refreshing the page

I’d love to hear it if it works, good luck.

Hi @eren

Thank you so much for responding.

I tried the work around you mentioned. But it shows some error.

Here is what I did. Please correct me if I am wrong.

I have input change I have run a update query → display list in RG → Go to page

And then on page load


And at the end I am not receiving a fresh data.

Could you please correct me ?


The only difference between us is that you send data to the page. I just added a parameter to the URL without sending data. If you don’t have to send data, can you delete this part and try again?

I have to pass the data since the page I am using is dynamic, type of content is marked with one of the table.

Any idea ? @eren

Adding a parameter should not cause this error. Do you have any new plugins? And did you experiment in safe mode as you wrote in the warning?

When I open the page and use “step-by-step” , then only I am able to see that error or else I don’t see that error occurring and data is also not getting refreshed on page.

When I tried in safe mode, the same thing is happening I am not seeing that error and data not getting refreshed.

I checked my own app again and it works. I’m sorry it didn’t help you. If you want send to me your editor link with PM (I do not promise to provide a definite solution)

Is it possible to send a screenshot of your workflow, so that I can have a look ?

of course, but there is nothing different anyway.

To refresh data from a SQL Connector call, I found that by sending a parameter that changes from call to call, as well as refreshing the control the data is in, gets the buffer refreshed in Bubble. I use a call to the Unix date/time stamp function and pass that as a parameter in my SQL call, even though I do not use it in my SQL procedure at all. That seems to make Bubble refill the buffer the data is in. I make the call to ‘Display List’ (under Repeating Group) or whatever container has the data being displayed with this. See below example (I call the parameter ‘bubble’ and pass it the Current date/time and use the extract UNIX option. Hope that helps.




Hey @davidb2

Thank you so much.

It worked !!! :smiley: