Forum Academy Marketplace Showcase Pricing Features

Unicode (utf-8) and database issue

Hello everybody.

I have a little problem with Unicode.

Our project is aimed at a Russian-speaking audience.
We are trying to connect our application with mysql through the plugin sql connector. The database in mysql has the encoding utf-8. When we add a new entry in Cyrillic via the app, the database table is written only this: “Васькин Р?ван Р?ванович”

I don’t know in what encoding the data is transferred from the bubble to the database.
How to transfer data in utf-8 through “sql connector”?

Is it possible? I will be glad to any help.
Thank you in advance

1 Like

Hi @victoriys2005,

Sounds like a tricky problem.

Can you check that the column has a collation of utf8, or “table default” and the table collation is utf8.

Can you check each source of the data and see if it is being altered.

I ran a test on a table with a utf8 column, inserted a value from a Bubble input text of “Добрый день, я надеюсь, у вас все хорошо.”, and it retrieved back okay.

EDIT - altering the language of the Bubble app didn’t seem to make a difference.

EDIT2 - I don’t understand Russian, hopefully the above automated translation isn’t offensive!

Good luck!
Misha

1 Like

I don’t understand Russian, hopefully the above automated translation isn’t offensive!

It’s correct, Thank you for responce.

We are looking for a solution to the problem, but, honestly, nothing has happened yet.
We checked the encoding settings everywhere. The settings are correct. We created a new database from one simple table. An error with encoding is still present.

Can you specify your sql query, which was added to the database entry?
Maybe we are mistaken in this.

Here is the insert:

And here is the select:

Workflow action for the insert:

Do you get a normal result for English text?

1 Like

Sadly, that’s exactly what we did.

In English everything works correctly.

Thank you very much for the reply. We will try now to install the database on another server. Maybe that’s the problem.

Victory!

The problem was in the server on which the database was installed. The server had problems with the encoding. And it could not be changed. We moved everything to another server and it all worked.

Mishav thank you very much for your contribution to solving this problem. When we realized that we are doing everything right, it became clear that maybe the problem was in the server. Thanks a lot!

1 Like