Update data in airtable With the Airtable Plugin


I’m using Airtable for data on my app, it works fine, but now I tried to update a record and nothing works, i tried goolge search but nothing, does anyone knows what do I have to type in the record input? I tried all my choices and nothing works :frowning:



There is a button “Re-initialize table” under “Modify Fields” that is inside the plugin. Like this:

ok, but that is to configure the table, my problem is that any combination that I try in the record field it always gets red :frowning:

Do you mind if I take a look at the editor?

Same problem. Can’t get record to not be red. No link to reference docs to explain.

Same problem: I used API connector to submit new records about users to Airtable’s database and it successfuly works for creation of new records. But when I tried to edit that data, I wasn’t able to match the editing field with existing user in database. Is there any way to say Airtable where exectly to edit (which user to choose) accross the table?

1 Like

Version 2 of the Airtable plugin has been released. I haven’t had a chance to check this particular issue yet, but a number of bugs and performance issues were addressed. Might want to re-try once your instance has the new version.

Was this problem resolved? How to find which record to modify?

any update on this? Im having the same issue.

Any Updates? Same issue.

Any updates? I can’t modify as well.

I have the same problem. It’s just not possible.

I too, am having this same issue.

Maybe a bunch of us should team up to problem solve all of these common Airtable - Bubble plugin issues, and then make a youtube channel about it. I am at my wits end.


Hi - was this ever fixed? Currently having the same problem trying to modify a record from bubble to airtable

1 Like

Can confirm that this thread works for this problem. It’s convoluted and totally unintuitive, but it works.

1 Like

Oh fantastic! Thanks for sharing ALB, I’ll try it out on my app.

I found thomas.gounot’s tip really helpful, but selecting “Items: first item” for the record confused me.
I decided to store the the airtable record reference in a custom state on the page

This allowed me to choose the record

1 Like