Upload file to Google Drive - API Error

Hi All,

First-time poster and Bubble Newbie.

I’m looking for some help uploading files to Google Drive from Bubble. I’ve been through the pain of setting up OAuth and have that all working so now I’m trying to setup the API call and test. I’ve not found much in the way of help on this so far so probably a long way off but this is the confg and error. Any help appreciated

Hey Zenziblesolutions, in the documentation it says uploadType should to be a url-parameter, so try it like this:

Or try this:

By using brackets [value] you can set the value of the parameter. To be able to set it later in the workflow, remember to uncheck the Private option.

Thanks for the response. I’ve tried both of those and get the same error. I’m not sure wha’s wrong, the error message doesn’t give much away.

Ah ok, you already tried that. To get more info about the errors you have to mark one or both of these options:


You will get more info. This will also allow you to look at the raw response which might give you even more info, hopefully also a HTTP status code.

Btw, in the documentation it says that you need to include a Header “Content-Length”, set to the total number of bytes in the request body (in case you did not try this yet :wink:).

1 Like

Thanks for the response. We are getting somewhere. I’m not understanding why this is the case but the file uploads when I run the reinitialize. It works!!

The problem in that the file (text/csv) has header/footer metadata that needs removing . Do you know why this is working with the capture response and include errors is checked?

1 Like

In this topic the author has the same problem:

because the file is created successfully, but it is untitled and has no format type, and the body contains this proprerties"

The solution in that topic was to add a header Content-Type with value application/json.

Try it, it might solve your problem.