URL slug dissapearing?

Hi,

On my app I have users create a page with their own slug. When i navigate to the page, i see the users data has been correctly pushed to the page and the URL contains the slug; however, as of today i just noticed that the latter part has changed: When a user creates their page and navigates to it, while loading, the url quickly changes from https://myapp.bubbleapps.io/pages/SLUG to https://myapp.bubbleapps.io/pages, so when users go to refresh the page, their is nothing there. Typing in https://myapp.bubbleapps.io/pages/SLUG manually results in the same behavior.

Is this a bug? Any help would be appreciated.

Note: The links are just for examples. This is not a browser specific issue, as i’ve tried it on different browsers and devices.

My app and co-workers have the same error, for dynamic pages, paths and parameters

1 Like

Okay, good to hear that it isn’t just me. Changing things unnecessarily is my least favorite thing to do :stuck_out_tongue: . I’m assuming then that this is a bug with dynamic pages in general. How long ago did this behavior happen for you? I just noticed now but it may have started before. Thank you for your quick reply.

Same here :frowning:

@josh - This is kind of critical since it breaks the apps behaviour. Can you fix this please?

Thanks a lot.

same here, it started around 30 mins - 1 hour ago. I thought it was my fault and cracked my head trying to find the issue

If you haven’t submitted bug reports yet, you should all do that asap.

This is happening on my app too!!! Users cannot login

It’s working perfect for me now

1 Like

Bug report submitted: #49425

At first I didn’t understand what was happening. When the information in the URL was lost on refresh, it caused all kinds of poor behavior in the rest of the app.

This is urgent.

check it now, is working for me now

You don’t have any action that changes the URL or accidentally navigates to the page without the slug so it appears and then immediately disappears? Like when Page is Loaded Navigate to Pages

Same here, working now

This topic was automatically closed after 70 days. New replies are no longer allowed.