Webp images converted to jpg?

I have a set of images on my index page, they are randomly re-called from the database “feature gallery” thing.
All the images are uploaded in the database as .Webp to improve the SEO score and page speed, however they are converted in jpg.

So if I try to open the images in a new tab, and then save, they area saved in .jpeg.


Is this behaviour normal?
It’s causing me a headache.


Bubble automatically process the images in the page to try to optimize them.
If you want to keep webp format you probably need to opt out from this. Add ?ignore_imgix=true at the end of the data source of the image and see if it works better for you.

Hi dorilama,
Thank you that works very well, now the format and size of the images is at it should be, and I will test again the page speed in a minute.

However, I cannot happen the string to a data source field in a Slideshow element (screenshot attached).

Do you know how to solve the issue here?

Thank you

use image for type of data and an array of text as data source (the urls of the images).
If you have the images in a search use format as text to create a list of text with the data you need and the added query string.


Thanks for your help,
I still need some tips I think.

I either get a text type at the end of the data source, or I can manage to get an images. In both cases there is something missing.

Am I doing it right?

You have a featuregallery as the type of image. Change that to image and the error should go away.

I still have the same problem unfortunately, bubble sees at a text.
If I add used as an image at the end of the data source string, I get an image, not a list.

I’ve also tried in the “format as a text” to convert the content as a list.

in format as text add a special character in the delimiter option, something like | (chose a character that is not in the text), then add split by with the same character used as delimiter.

If from your search you already get a list of pictures, instead of the format as you can use each item find and replace with regex expression enabled. Set $ as the pattern to search and add ?ignore_imgix=true as the text to replace.

1 Like

This topic was automatically closed after 70 days. New replies are no longer allowed.