Websocket and wrappers ? Data not being updated


I have been reading the forum a lot, trying to find definitive answers on this topic.

I have recieved feedback from clients that sometimes data displayed on their app stops being updated. It’s data from the Bubble database displayed in repeating groups. (nothing more standard). We have an iOS and Android application wrapped with “Jasonette”.

I have tried to replicate the issue on my phone (Android) but I could not recreate a situation where the bug happens. I have yet to try on iOS.

I was wondering if someone was able to tell me :

  1. When does this bug occurs ? What is the origin of it ? What’s going on precisely ?
  2. Is there any standard solution that doesn’t feel like a temporary fix ?

I tried to contact Bubble support about this but as app wrapping is not officially supported, they were unable to answer my questions on this topic.

Thank you very much in advance,

It only occurs on iOS. It is a longstanding issue with Jasonelle that no one seems to have a fix for.

Hi @florian1 @aj11

The problem seems that iOS reports the app as ‘asleep’ after 10-15 minutes. I recommend to make a routine inside Jasonelle, which sends a request to a Bubble API every 8 minutes to re-initialize iOS. This is just a theory that I will try to validate in the next weeks.

With recent WU calculation, maybe ping on apple.com

1 Like

It’s ok for the app to go to sleep, as having it always awake would drain battery life. The issue is that when the app “wakes up” again the websockets are not turned on again and stay asleep. If you force your bubble app to make a new search, it turns the websockets for that search back on, but not for the other websockets in your app. I believe this is something Bubble needs to fix, I’ve spoken with them before about adding a “refresh websockets” action, but I’ve always been told this won’t be happening since it isn’t needed except for wrappers.

1 Like

This topic was automatically closed after 14 days. New replies are no longer allowed.