What's a work around for my missing 0?

Hi all,

Im trying to save an australian phone number which contains 10 numbers and starts with 0.
However whenever I save the number it removes the starting 0, anyway to keep it there?


I suggest saving the phone number as text, rather than a number type, as the number type is really just for mathematical calculations or expressions.

So probably best to change the data type from number to text. The number type field has to be a whole number, whether its a decimal or integer.

Ive tried this but does the same. I assume bubble thinks 0 means nothing so remove it but my numbers look odd missing it. mm

Make sure that the input element you are using to capture the phone number is set correctly.

You can either use:
Wont allow spaces

Probably the best option

US phone number formatting

As long as you are saving the data to a field set as text, it will be able to store the numbers leading with a 0.

HI all,

I have tested all of these and found the following:

Saving as a text field - means that the numbers are not saved in the database. it just fails.

US Phone number does not have the correct number of digits for the UK - we loose numbers.

Text numbers only still removes the zero.

Am I doing something wrong. I have spent time testing all permutations of data input types and saving in the database (under different data types).

My resolution at the moment is to add a zero in the display windows and just accept that the zero will not save.

In addition I am trying to work out how to stop the user progressing unless they have entered to following:

11 digits for a mobile number
the number starts with 07 - this is the most important
the field is not blank

I have been trying to work it out in the conditional formatting in the field rather that the save button. Is anyone able to provide any direction on this topic.

I tried to save phone number as a text and don’t have any problems with that.Screenshot_2020-04-25 Bubble Editor - Biolink

About progressing, you can add conditional when mobile number is not 11 digits button save doesn’t work.


Thank you for getting back to me. If possible could you confirm that the element was a text field and the database field is text? or maybe number? I will retest, I thought I had got all the permutations but I must of missed one.

With the spacing of your digits how did you do that. 4 digits then a dash?

Thank you for all the help :slight_smile:

input type - text
database field type - text

it’s random numbers doesn’t really matter what it is. Can be 0808090-ADV-45646_da+das

it worked, ugh I spent so much time on this for such a simple solution.

Thank you so much, it could have been so much worse!


Not sure if you are ready for another one. I have done my best to be able to create a calendar that i could select a date range and ten an event would be created every 7 days. I did this by creating a new event and then used a custom events to get me where i need to be.

The orange workflows show the scenarios that work.

The system is flawed because i do to capture the duration of the events.

To resolve this i switched the date inputs from AirDate/TimePicker C to the AirDateDropper and AirTimeDropper . Now I can get the duration but my attempts to get the weekly workflow to work again have failed.

Everything looks the same - any chance anyone can have a look and point out what i am doing wrong?

I can create one event successfully - it is getting the custom events to trigger and create multiple events that is broken.

Any help would be a life saver - i cannot stare at it anymore :slight_smile: