Forum Academy Marketplace Showcase Pricing Features

Workflow API having trouble entering "[" brackets

Hi all,

Unfortunately one of my API providers has quite a weird naming. One required field for example is called rooms[name]. However, bubble doesnt allow me to enter brackets into the key field of the workflow API.

Is there any way to circumvent this, as else I wont be able to integrate this into my app.

BTW. I have not yet looked at the plugin requirements for the open source community, but if that problem can be solved I could also easily implement this as a native feature for all bubblers. The service is a live voice chatting API.

Best,
Jan

Hi Jan,

It might be that Rooms is actually an array of multiple "name"s? If so, you’ll need to enter this into the body text box. Could you share a link to the documentation for this call?

Some API use these to define a child parameter : Parameter[ChildParamter]

See here the metadata[order_id]=6735 in the request, it corresponds in the response to :

metadata”: {
“order_id”: “6735”
},

Right, so in @nicolas.daprigny’s example, you’d put this in the body instead of the parameter fields:

“metadata”: {
“order_id”: " < order_ id > "
}

You’d see a new key : value field show up for order_id (produced by the <>) so that this field can be dynamic.


Gaby | Coaching Bubble

1 Like

Hey!

thanks for your replies, I will try it out in a moment (even though I am not sure how to actually do that).

I “reverse engineered” their api with the chrome wrapapi addon (super useful!) and the screenshot shows what I got:

Eventually I habe two times “room” with a following bracket, so not quite sure how to tell bubble which is which.

Thanks!

Hi, I am having same issue in stripe setting.
I am tring to attach customer information to stripe “metadata”.
https://stripe.com/docs/api/metadata

When I try to update customer info, the API connector says an error below.
Do you have any solution for this error message?

That is not valid json. Try this…

 "metadata": {
    "passport_number": "<passport_number>"
}

thank you for replying.
I tried as you mention, but am facing this error.

I just read the documentation. You need to add parameter metadata[passport_number] and the value of that parameter should be the passport number you are trying to update.