Forum Academy Marketplace Showcase Pricing Features

Workflow inconsistency

I am using the keystroke input trigger plugin to make a “when input changed” workflow that doesn’t require clicking away from the input to trigger the workflow (which the out of the box one does for some reason).

But I am getting really strange behavior where i run through the steps multiple times, and get different results. If I do a step buy step debugger sequence it works correctly, but if I do run normal it the result is different.

I have done this many time but in the video I recorded I’m showing just one full cycle of this (with a few times of erasing text and retyping with step by step to show that it always works and go back to normal for the last round to show how it does something else (i.e. the text that it prints below).

See video here.

Any pointers are welcome.

Thanks!

Based on the video, I can’t say if this is a bubble issue or a plugin not firing issue.
Have you tried checking the “breakpoint” checkbox on the workflow to troubleshoot?

Sometimes the step by step doesn’t pick up workflows firing and the bubble debug mode will often ‘miss’ events that fire—especially when the timing is tight or there is some kinds of asynchronous behavior.

An advanced trick, you may want to try using the toolbox plug-in by mishav to log the result of your workflow to your browser’s console. Then you can the open the browser developer mode and observe exactly what is firing or if the step is firing multiple times.

You can log your workflow data to the console by including the ‘Run JavaScript’ to your workflow and use this code in that step with your dynamic expression between the quotes.

Console.log(“state’s value”)

You may find the workflow is firing differently than you were expecting and can tweak the settings of the plug-in or your logic to correct it. Also it may reveal an issue with the plug-in