Zapier creating unresolvable issues

Hi, does anyone have any experience of Zapier creating random unresolvable issues with your Bubble app? I have a contractor from Fiverr creating a zap for me. They don’t have access to by Bubble app but I have connected Bubble to Zapier.

I was in the editor and there were zero issues. I closed the editor and re-opened it and now have 25 issues in the same version. The issues don’t make any sense and cannot be resolved, for example:

The last step in a workflow navigates the user to another page. The page has type Review so in “Data to send” I’ve selected the review which was created 2 steps earlier (See screenshot). However, the issue says "Go to page… " is not a possible option.

The page definitely exists and has type Review.

Any help appreciated.

BUMP. I still desperately need help with this. Reported this to Bubble and they’ve been completely useless.

Your step 2 above executes whether or not step 1 completes. It should have an only when of “result of step 1 is not empty”.

But further we don’t know what other conditions you have on the workflow, so can’t help further.

Also, looks like a bunch of your warnings are on one page “old_index”. If you click the issue it’ll take you right to where the problem is. Did you perhaps mean to delete old_index now that you’ve moved on?

Just some things to understand and check.

Thank you for trying to help @keith .

The problem isn’t that I can’t figure out how to resolve the issues, it’s that they are illegitimate issues. Anywhere I have navigation to a Type of page in a workflow, it’s saying it’s not possible.

These issues popped up out of nowhere after zero changes were made inside my app and they cannot be resolved.

Customer service at Bubble have said they can’t even see them.

I’ve tried clearing my cache and using a different browser but they’re still there. For the sake of argument I added the “is not empty” to the issue you were talking about but it’s still unresolved.

The zaps have been turned off so it can’t even be that anymore. I’m perplexed and immobilized.

Have you tried making a copy of your app with the database to see if the copy suffers the same issue?

I have asked Bubble to make all versions of my app match the Live version. So far, there are no issues anymore.

Now I will only make changes using the Development version. If I touch my second development version it will only be to test out designs/ideas. I found some other threads on here where people have issues after deploying from their second development version so I’m going to avoid that in future.