Forum Academy Marketplace Showcase Pricing Features

Zapier working Inconsistently

Anyone have issues with Zapier reading data inconsistently from Bubble when setting up Zaps?

I have a few Zaps working great but others just refuse to connect because seemingly the data isn’t being read from Bubble.

Below is one example that I’m including because it is the most simple version of the issue but I’ve run into the same issue a bunch using other end points (Airtable, for example).

I’ve found when grabbing the data from the dropdown in Zapier it needs to no longer say “Querystring Text 1” but instead “Text 1 some actual.” I’ve tried waiting a few hours/days, deploying, retesting step one in the Zap, refreshing fields in step two of the Zap, but it doesn’t always work.

Anyone else running into this?

Zapier keeps telling me that because Bubble is in Beta they really can’t help…

Here’s the sample: I have a workflow that charges one user and pays another user. I’d like to trigger a Zap to add each user to the appropriate Mailchimp group (customer/seller).

I’ve initiated here:

Tested it successfully here:

Tried to grab the email here:

And it fails:

Thanks all!
Jen

Hi, since I am currently going through the same issue I was wondering if you have solved it ? Thanks

Yes!

Actually, @jonathan.timianko solved it.

Here’s the trick he discovered. And it works.

So it’s annoying, but whenever you make updates or changes you need to go back into Bubble, run the page in preview mode, complete the workflow from the user side, and that essentially “sends” the data to Bubble so it recognizes what is happening.

The key is running the entire workflow in preview mode and then returning to the Zap to refresh the page and find the expected options.

Full thread here:
https://forum.bubble.io/t/same-issue-as-you-on-zapier/10456/5