Zapier Issue - Trigger a Zap

Hi all,

I am trying to use the Zapier integration to send user email and first name to Zapier, so I can create a user in Intercom.

Although it appears to be set up ok, I always get a failure from Zapier emailed to me as below:

How can I fix this?

It looks like the data Bubble is sending using the Trigger a Zap action isn’t correct. I have tried hardcoding an email/first name and using dynamic data.



Hi @help,

have you solved the issue ? I am having the same problem with what should be an easy integration with Mailchimp. In Bubble an action triggers a Zapier Zap but then in Zapier I do not see any data. It looks like this:

querystring__text_1: text 1
querystring__text_2: text 2

while it should be something like

querystring__text_1: [email protected]
querystring__text_2: a random number

Hope you can help. Thanks

1 Like

In your Zapier trigger step (which I assume is a Catch Hook), look in the Find Data tab. It will give you several data samples if you hit it multiple times.

You can see the data that is coming through here. Make sure the one you selected has data in it before setting up the rest of your Zap or you will have errors even if the trigger is configured properly.

If you have no data here, there is something amiss in the way you’ve set it up in Bubble. If you have correct data here, the issue is in how the Zap is configured.

Hi – having this exact problem, but I feel like everything is set up properly? im not receiving actual data just “querystring_text_1: text 1”… any ideas?


I’m having the same problem! Did you find a solution for this?

Also having the same issue - any solutions?