Connecting Zapier TO Bubble API

I can connect Bubble to Zapier nicely, and am storing email in MailChimp.

Thought I could then use the Bubble API to allow Zapier to trigger Bubble workflows as a Zapier Action.

I think I sort of get how it works (can’t figure out the authentication so left it off) but it just hangs at the Connect Account stage.

Anyone got any further ?

@NigelG Did you ever figure out the intergration? Am confused as well. Trying to bulk email a list of people that are following a user and believe I could complete that task with Zapier.

Hi @BenBowdenE

Yeah, I have a feeling the Zapier “in” as well as “out” … could be huge.

No, I haven’t yet. But my failures where more to do with me just crashing in and doing it. And not really reading the docs :slightly_smiling:

Yesterday I read the “Introduction to APIs” tutorial (which is fantastic) and am now ready to have another go.

My issues was not understanding the need for the API authentication trigger.

For non programmers this is a great, and fairly short, course.

Should have more feedback by the end of the weekend. If I can get it to work then I can try to make it public.

I found, however, that API documentation is fairly poorly written for the non technical person. I don’t understand why they need write an essay on something that is programmatic.

1 Like

I was nearly there…

The issue is that Zapier uses a GET to do the authentication. And I can get that to work nicely (I am seeing bubble data coming back into Zapier).

Then I do a POST to the workflow endpoint and am told it is not authenticated.

So I am wondering if the authentication was done on this endpoint…

Is not valid on the workflow endpoint…

Any thoughts @emmanuel ?

The error I get is … "You must authenticate to call this method "

Might try to remove authentication and see what happens.

You have two options for authentication, either put the api_token in the URL as a query string, or in the body of the request (for POST). you can also make the call not authenticated, but be careful with this

I am confused now. The documentation says the api_token should be in the header ?

I can authenticate perfectly well with the token in the header on a GET

But then when I use that token for a PUT on the workflow end point, I am told it is not authenticated.

I am kinda thinking I need to authenticate “higher up”.

Well, if I take the authentication off I can run a workflow from zapier to create a new thing from a workflow in Bubble.

This is quite cool.

But…the authentication bit isn’t working and this is key.

Sorry i take it back, header or in the URL. What do you mean by PUT? We don’t support this method yet.

I meant POST :slightly_smiling:

Taking a while to get used to the terminology !

GET works fine, POST to the workflow endpoint using the token from the GET is the issue.

Have you tried with curl? If it breaks, can you paste here what you did (no need to show the key itself, can replace with ‘xxxx’)

I am not sure I am ready for curl !

Will try in Postman or something like that.

OK, I can get the POST to work with auth via POSTMAN.

So am assuming this is a Zapier issue.

We’ll make sure zapier sends the right request. That’s likely where the issue is. We’ll look at assign a bubble webhook in zapier so that people can just do that with a preset zap.


Thanks, that would be great.

Ok, so apparently I need to add “Session Based Auth” to my API call. So do a GET on something that will always be there (OBJ/USER seems perfect for this) and then store the token and use it for the POST in the same session.

Great, I get it. I see how it works. But I need to be able to program in Javascript to do this. Someone on Fiverr is suggesting $25 for this, my guess that is about $1 a line of code. No way.

Really can’t see how Zapier can claim you don’t need to be a programmer to integrate an API when you clearly do.

Anyway, this has to be something done frequently…but Zapier have no forum. Where would I go to ask ? Stackoverflow ?


I don’t see why I can’t just pass the api-key on the post.

It works manually, why won’t it work via Zapier.

Well, I was right :slightly_smiling: … and saved myself $25.

I needed to add the following to the authorisation.

Oddly, the GET to Bubble worked OK with the standard Zapier auth mapping, but the POST needed it as above.


Thanks for that! Will try it further. Also I had no idea earlier, that this problem can be resolved in such a simple manner.

1 Like