Forum Academy Marketplace Showcase Pricing Features

Zapier Not Formatting Properly

Hello all,

After chugging through my app to finally get it working, I’ve managed to integrate it with my Google sheets without any trouble. However, the times that I’m recording on my app and then transferring into my sheet is coming back as an entire data and time with seconds. I just want it in the format h:mm AM/PM.

I’ve tried formatting the sheet, but it overwrites it. I’ve tried using the zapier formatting app to try and process the dates before going to the sheet and can’t seem to get that to work either.

Any help would be appreciated!

@craig.stritar I’ve had that before.

Here’s a trick. Instead of just sending the output of the zap to Google Sheet, send this equation instead:

=query(split("[date]"," "),“select Col1”)

where [date] is date sent by Bubble.

Basically, that tells the Google sheet “Take this string, find the space, then only keep everything before the space”. You’ll then up with just the date on your Google Sheet.

So setup like this:

And you’ll end up with this:

Hope that helps!

Your fix works perfectly for the date however, I am trying to just be left with the time. I changed the query to search for column2 instead of 1, but that just gives me 12:00 no matter what time it may actually be. Any other tricks you may know of?

Hmm, that’s odd.

Any chance you can give me read-only access to the Google Sheet and I can check the problem is there or Zapier.

[email protected]

1 Like

Sure there you go. I’m sure it’s something I’ve overlooked but I’m so new to this it’s hard to follow everything. I do appreciate your help though!

https://bubble.io/page?version=test&name=index&id=patienttransport&tab=tabs-1

No I mean invite me to the Google Sheet you have setup.

Could you run a Zapier cycle so there is a row with the error on for me to take a look at. Cheers!

I had to mess around with the column number a little more to understand. But I did manage to get it working. One last thing is there any way I can remove the seconds from the time stamp?

Currently, the time appears (with your split function) as hh:mm:ss AM/PM. Any way I can remove the seconds?

Thanks!

This topic was automatically closed after 70 days. New replies are no longer allowed.