1014 Error - CNAME Cross-User Banned

This is an ongoing issue for me with no resolution in sight.

I have spoken on the main “Cloudflare for all” thread and it was confirmed that my settings were correct but I still get the occasional email from bubble saying that there is a problem and then today whilst I was in the app I got a 1014 error that totally crashed the app: https://share.getcloudapp.com/X6uOB5X2

After a few minutes it came back up but there is clearly a problem that needs urgently sorting.

I have never had an issue with CNAME and nameservers in the past but I am by no means an expert.

I’m open to any ideas on how to achieve a solution and if required I’m willing to pay. I just need this fixing as a matter of urgency.

Thanks in advance

1 Like

I’ve just come off the phone with my domain manager and they have confirmed that I cannot have the CNAME and the A record of my app with the same address.

So my.appdomain.com A record and my.appdomain.com CNAME cannot co-exist.

I have removed the CNAME, updated the A Record and there is still no joy. I understand that could be propagation issues but I have no confidence that the issue is resolved meaning that the problem could take days to sort as I keep trying out new configurations when each attempted solution fails.

It does look like the propagation has already taken place: https://share.getcloudapp.com/mXuBjG7e

The app is still not live and my bubble dashboard states that “We found a bad DNS records for my.domain.com. These records are pointing to the servers that do not belong to Bubble: A record, A record”

1 Like

Maybe it is a propagation issue as the app on the bubble dashboard now says “we’re good to go” but the app isn’t live.

Then when I refresh the error message comes back up.

Looks like it’s a case of wait and see what happens

1 Like

I started having this same issue last night and now I am not able to preview my app

Have you had any luck?

I’ve removed one of the A records as recommended by Bubble support so now I have just one A record pointing to the app but it’s still showing as down.

My next course of action is to delete the custom domain and go through the process again… I was wondering if you had any luck before I do that.

I changed my cnames from “proxied” to “dns only” it solved my problem

I really wish there was some official (Bubble) documentation on this. Grrrr

1 Like

Hi, it turns out that this was an actual bug that the bubble engineers needed to resolve with Cloudflare. Since then I have had another issue on another domain but that was caused because in Cloudflare I had the orange cloud showing when it needs to be only a DNS record.

interesting. i’ll have to give it another try then! thanks for the update man!

This topic was automatically closed after 70 days. New replies are no longer allowed.