Custom domain is not working - Error 1000

our app had a working custom domain, and we tried to make updates to this domain and then retrieve it back to the original domain which was working.
Now our domain is not working and give error 1000 DNS points to prohibited IP
even the bubble app default domain not working and redirect to this custom domain and give the same error

so now our app is not accessible at all

Hey @momen,

Maybe try adding a new CNAME record for that subdomain with the value of:

Thank you @johnny for advice, but it is not possible to add CNAME with record added as A

Hey @momen,

If you remove the A records that Bubble gave you then have a CName of it should work.

It worked for me

Hey @johnny ,

Unfortunately this didn’t work

Did you turn off the orange cloud? To make it DNS mode.

yes it is dns only


For any one has the same problem ,
this issue was from Cloudflare account , as the domain is flagged and can’t be connected to bubble. so problem solved after contacted with Cloudflare support and ask to unlock the domain


hello i have tried all, and stuck with the same error, cloudflare says that they cant point their own ips, this issue only occours to people with cloudflare dns hosting


Hi @aiudappgg,

Did you turn off the orange cloud on Cloudflare?

1 Like

Thanks for this tip @johnny.

I lost a few hours looking for this. App online now :wave:

1 Like

You can (and should) have the orange proxy setting turned on for Cloudflare and this definitely works. I host through Cloudflare and have DNS with them on a number of domains and subdomains all pointing back to the main Bubble cluster IP.

If You’ve waited a few hours and it still doesn’t work try removing one of the records and hitting your site again - this sometimes gives everything a poke and has worked for me in the past. You can then just re-add the extra record.

Cheers - johnnyweb

How grateful I am to you guys