"Issue with your domain name" error message

Hi everyone,
Today I was working on a small feature within my app, and suddenly when I tried to preview it the following message appeared:

There has not been any DNS changes. Does anyone know what could be the cause for this error appearing so randomly?


I just saw that as well. My guess is that there was a minor update to Bubble, and the message has been shown erroneously.

Especially if you, I and anyone else got it without changing anything.

I was worried for a second that my domain name had expired, but the fact you got the message as well means I can comfortably ignore it.


I just saw it too.

I noticed that the A records I had in Cloudflare were different than the ones Bubble was showing me.

When I replaced the IPs, my app got out of service - even though the DNS was already propagated. I switched it back to the original IPs and it looks everything is fine now again - the Bubble error message is still there.

I think it’s a bug.


Thank you @SJL and @gabriel.guilhem. As both of you suggest if this is something appearing without any real cause, it might as well be a bug.

I’m having this issue too. My website is currently down using the new DNS records.

1 Like

Same, changing the dns caused cloudflare 1000 error, reverting to previous works, but with this error popping up

1 Like

same issue here. what should we do?

1 Like

Same here

1 Like

Getting the same issue across several apps, unusable at the moment.

Same problem here! Everything was working fine and now my settings page is telling me I haven’t got SSL anymore and that my app has ‘bad DNS records’… :scream:
Any idea on how to fix that??

You should all submit bug reports, if you haven’t done so already.

Seeing this on my end as well.

Bubble support advises to not change your DNS settings to the ones recommended in the ‘domain settings’ tab… It seems they’re working on it.


Thanks. I was literally just about to do that :grin: .

1 Like

I would say by reading everyone’s posts DO NOT CHANGE ANYTHING based on the message.

The message is an error, your existing settings are fine.

The only people who seem to have had issues are those who proceeded to change records based on the message.


Changed nothing (i,e sit and wait for Bubble to resolve).

This morning it had gone away, so thought all was well.

Now its back again.


Can confirm this also. I was connecting a project to a domain but the IPs provided result in DNS resolve issue (cloudflare page). The project was using standard bubble domain but had a custom domain a few months back. Support said they are aware and it’s been almost 48 hours to date.

1 Like

The DNS error went away for me. Everything seems to be working correctly now (at least for me).

@dan8 you still getting Error 1001 for the new domain connection? It’s frustrating it’s been a few days and still not fixed…


Not anymore. I was advised to use an older IP range which my project was previously connected to. After using this for the A records, it started working again. So, if you had previous IP records assigned, use those.