Adding item to drop down list...only working when running step by step through the debugger

I have created a dropdown on a PopUp that enables a User to pick an item or to Add a New Item.
When they select Add an Item, another PopUp opens, they add the item details, hit “Save” and then the item should be visible in the list of items.

Here’s a screen shot of the data source of the pop up in case that’s of interest…
There are two searches merged together - the first one adds the “Add New Item” option at the top of the list and the second one filters all that Users’s products.

Weird thing is, when I run this in real time, it doesn’t work. I then have to click an icon I created as a workaround that hides then shows the PopUp so that the item the user just entered is available in the drop down.
However, when I run this step by step in the debugger and watch each step of the workflows running, it works as expected with the item the user just added being immediately available in the dropdown list without my having to press the workaround “refresh” icon.
So I’m wondering if this is a bug but, hey, I’m by no means an expert user so it could be something odd I’ve done or that I simply don’t know about but it just seems odd to me that it only works when run step by step in the debugger.

Hi there, @joefarrowsmith… after you mentioned this setup/scenario in your other thread, I actually tested it, and it worked fine for me. So, maybe it has something to do with your workflow? It couldn’t hurt to share screenshots of the actions, and it might be as simple as adding a pause action somewhere in the workflow.


Hi Mike
Here’s a link to it…

Basically, someone with a venue can add their own products to that venue. Those are stored as “Basic Products” which they can then sell at whatever price they want through any outlet they might own. To see items that a venue sells, click on the “Menu” icon next to a venue (knife and fork thing).

It’s a bit of a mess in places, I know…

It’s a bit difficult to piece everything together, but here’s the first thing I would try, and I have no idea if it will work. I don’t think you need the highlighted step in this workflow because if I saw things correctly, you are already hiding that popup as part of another workflow. So, try replacing that step with the Add a pause before next action event and see if that does anything.

1 Like

Mike, You genius! Thank you so much. I wasn’t aware of “Add a Pause” action so I’m not entirely sure what it does but it works.
I’ll research it now and will probably use it in future.
Thanks again. You’re a star.
All the best

1 Like

My apologies if I made things trickier for you…I changed the settings to “Anyone Can Edit” but on going back in just now to put them back to Private, I noticed they were set to “Anyone Can View”. Sorry if this hindered you. You still managed to find the solution however. Thanks again.

1 Like

No worries, Joe… happy to help. About the pause action, what led me down that path is you saying it worked when you ran the workflow in step-by-step mode. When you run a workflow in that mode, you are forcing the steps to run in order, as opposed to the way the steps run when the workflow is run normally. So, if it worked when the steps were run in order, sometimes adding a pause in the workflow can help. Anyway, just something to think about there.

Oh, and just a heads up, I wouldn’t set your app to Anyone can edit and post a link to the editor in a public thread. You just never know who might hit the link and do whatever they want in your app.

Thank you for both bits of information there. I didn’t know if enabling view only would let someone see the design end of it but duly noted for future!

Have a lovely day.

1 Like

This topic was automatically closed after 14 days. New replies are no longer allowed.