Addition not working


Can someone idiot check my work - it is a simple addition but for some reason I cannot get it to work.

just one field + another field (the two in the red box) = so one value is 20 and the another is zero - so add them together and you get 20. Not what i got though i got nothing!!!

Why ??? sob! can anyone work it out.



I’d check that the values from the two inputs you’ve highlighted in red are indeed correct - perhaps add a text element need to each input that use the same dynamic expression to check the value being pulled in is 20 and 0 like you’ve mentioned.

Also double check that each input is correctly formatted in the type of data under the ‘Content format’ dropdown.

Happy to check if you want to share the editor here or via PM.

Hey Thanks,

the content format is currency i have checked that. I am not sure what you mean by adding a text element? Text elements do not allow for addition?

Hey @rachel.camp900

I’ve had a quick glance and although I couldn’t authenticate login as a user to properly test via ‘Users’ ran as method - I can see that the inputs values are all in the placeholders of the inputs, rather than the initial content of an input. So the last input ‘total’ is essentially calling the inputs with no values and expressing 0 as no values are added - see what I mean?



Also you’ll want to change the inputs value for the input ‘Total Money Due’ as its set to text at the moment, rather than say Currency or Number.

i did it and it worked.

Thank you :slight_smile:

it was really bugging me!

Great! Glad you’ve got it working.

Please mark this post as resolved for future Bubblers.

Sorry to be a pain but I cannot see where to do that?

Ok I have done it, the problem is that it did not mark the whole tread as solved but I guess that is ok.