Application primary language not working

Hi guys, I created a website in English and just translated everything to German and added a button on top to toggle between languages. I have now set the application primary language to German however when I load up the page in incognito mode, it still shows the English page instead of the German page. Can anyone please advise what could be wrong?

Thank you!

What program are you using to make these translations? Are you talking about the default language as in the Bubble Settings Language tab? Not quite sure what you mean.

@johnny Yes it is the Bubble Settings Language tab that I was talking about and used for my app.

How do I change the primary language in the workflow?

Set up data type under user called language, assign say english as the default option. Then add a language button on the page, everytime people click say DE/FR, change the user language to DE/FR.

This topic was automatically closed after 70 days. New replies are no longer allowed.