Forum Academy Marketplace Showcase Pricing Features

Basic Header Navigation

Hi,
I’m happy to say I’ve turned a corner with Bubble recently and well underway BUT…

One simple thing is proving harder than expected, which is:

I have several basic sections of my app. Each of which simply has a table with a Create New button so all I need is some links in the header to take me to each of those pages. I’m obviously missing something but when I try to simply make each of the text boxes in the header link to an internal pages I seem to disappear into a world of options.

eg:
Text box: Customers
Link Dest: Internal Page
Destination page: List Customers (I’d like to just stop here but then…)
Data to send: Do a search for - Customers - then I seem to be given a never ending list of requirements…

I’ve searched but can’t find the answer anywhere.

Many thanks.

If you show screenshots of your current set up, it will help the community trouble shoot your problem.

Not sure what I could show you that would help but here’s a shot of the text boxes I’d like to link.
Is that what you mean?

Basically just want to link a text box to an internal page.

image

I mean that we need to see your current workflows.

So I’ve tried both Text boxes and Buttons.

A few tips that will help you troubleshoot moving forward:

  1. Use the issue tracker. This will usually tell you valuable information about what the problem is. You always want to have no issues here. If you have any, you should work on removing them.
    Screen Shot 2020-05-20 at 6.53.10 AM
  2. In your case, the issue will say something like this (except yours will say customers where mine says teams):
    Screen Shot 2020-05-20 at 6.51.33 AM
    The issue is telling you that Bubble is looking for a single customer while you are trying to send a list (many).

To fix this:

  1. Leave the data to send blank. This should be used when the destination page is for a single record. Since you are going to set up a list on the destination page, you don’t need to fill it in.
  2. Retrieve the list of records once you are on the customer page. You will do this within the repeating group you set up by doing a search in the data source.

Thankyou for your help so far. Your reply makes sense but…
Bubble is not happy with me leaving the ‘Data to Send’ blank. I have the red-outlined Click prompt.

FYI: The navigation actually works, but of course the issue tracker display the error.

I wonder wold anyone else be able to help me here…?

Hi.
Is the the page you sending people to dynamic or just a static page?

Its my list of Customers (repeating group).

So I thought it may require something like - Do a Search for > Customers …
but the options don’t seem to end.

I just want to navigate to that page. Do I need to send data considering the page takes care of loading the data all on its own.

If theres anyone out there wiling to help I’d really really appreciate it. I know the answer has got to be simple but I’ve searched and searched and cannot find the answer.

With thanks.

The page must be dynamic and it’s wanting to know what data to show. Does the conditions of the rg rely on a user or previous step?

What’s the page content set to

If you want, share a link to your app and I’ll have a look into it.

Perhaps if you really want to get around it you could just use ‘open an external link’ and just manually link to the said page.

1 Like

Thanks Dylan,
No it doesn’t rely on a previous step. Its the same scenario as say… icons in the footer of an app. Just switching between various areas.

Does this link work for you?

Yes the link loads with a few users. How did you figure it out?

1 Like

I haven’t.
I still get the error in the screenshot. I can make it work, but I still have red in the Data to Send field and therefore Issues to fix.

Haven’t figured this out yet.

So, I’m building a phone app. The examples above will behave just like the icons across the bottom of most phone apps. Literally just jumping fro one section of the app to another. No processing. Just like many web apps, the user will be taken to a list, from there they can open a record or create a new one.

Yes, I’m having the same problem, how to navigate without sending data