Forum Academy Marketplace Showcase Pricing Features

Block Google Chrome Autofill


Does anyone know how to remove or eliminate the Google? I created a group that shows a repeatable group with the search results, but Google gets in the way:

Do I need to turn something off? Use a different field type etc…?

I see @josh15 had a similar issue 9 months back - Does anyone else have this automatic dropdown on their search bars?



First time I see this. I am sure you checked your extensions. See how it behaves in another browser.

Yes. You can delete your Google Autofill data but it comes back.

But I want to ensue the end users don’t have the same issue… so I am looking for a way to stop the browser from keeping the data for Autofill…

If they cannot see the options, they may get frustrated with my app…


1 Like

Worst case scenario consider building a custom dropdown. Here an excellent reference video by @gregjohnkeegan Custom Dropdowns | Tutorial

Don’t use a ‘repeatable group’ within a ‘group focus’ as a ‘dropdown’. Use Bubble’s dropdown element and show dynamic results!


I have used the default dropdown for some option sets in my database where there are ~4-8 items in the dropdown.

I can’t use the default dropdown for certain areas of my app, as some customers will have hundred or thousands of records. They’ll need a way to search the database for the item they want:


Yeah you can :))

Just apply a filter/formula to the dynamic results so that it only shows a certain amount.

To improve those search results as well, you can install a plugin which can do ‘fuzzy’ searching!

1 Like

I got a solution to this.

Previously, I could type text into the input field and it would narrow down the list in my repeating group, or I could click an item on the repeating group and it would be supplanted into the input field.

This simple fix was suggested to me by Steve S. He recommended I disable the input field. That way the user cannot write into it and Google will not try AutoFill it:

I also add a second search field so the user can type in some characters to narrow down the list. They then click the item in the repeating group to populate the input field.

All good thoughts everyone! What are ya’lls thoughts on how to handle this with a search box that is pulling geographic places from the google maps API? Very useful feature, but autofill makes it almost useless.

Suggestions through code seem to look like “Which solved the issue for me is setting the form fields to read only and then removing the attribute once the user focus them.”

I tried to disable the search box and then set a conditional that tries to enable the search box when it’s focused on to mimick that code, but it remains disabled.

disabled conditional

Would appreciate any feedback!


Hi @arensbpa did you find a solution for this issue? I’m having the same problem: need the geographic places autofill to work and having the chrome search box autofill covering the results.
If you have some ideas to share, it would be much appreciated.

Hi guys, were either of you able to resolve this issue? I’m also struggling with my geographic places SearchBox being covered by chrome autofill.

Kinda solved: For the address topic, I’ve got a plugin (google places autocomplete from Zeroqode) and it’s working fine.
But for other input fields (search for users or other types of data), I’m still bumping into the big suggestions window from last searches…

hi @vnihoul77 thanks for letting me know about this plugin. I’ve bought it but it’s not working for my inputs. I’ve placed the plugin next to the inputs I wanted to disable, then filled the input ID field and chosen the option “desactivate” but it hasn’t change the input behaviour and the autocomplete still showing up. Any tip to share?

Is this happening on Chrome? Did you already fill this field on this browser?
You could try on incognito mode, might be that your browser saved the type field.

Hi :clap:

Just in case you’re still looking, we have released a plugin that allows you to determine the auto-completion data type of a specific input or deactivate it :slight_smile:

Check out its presentation here