Forum Academy Marketplace Showcase Pricing Features

Blockspring read spreadsheet problem

I’m having an issue reading a spreadsheet with Blockspring. Everything seems to be configured correctly. The test run shows the actual data, but when i try to show it in Bubble it’s all empty. I tried both repeating group and “excel table” plugin
Here are a few screenshots:




Can you share a run mode link?

here it is https://kurve.bubbleapps.io/version-test/index?debug_mode=true

Please check your setting, when i run it locally, i see "Blockspring error: “File not found: https://docs.google.com/spreadsheets/d/1hXsUpcdJhuKK3E_qaZRbOTGXe-bz9OWOj5BIs1XOuE8/edit#gid=0"”

We’ll fix the error messaging thing soon so that you can see this, but it seems to be the issue (for now).

Blockspring’s integration with Spreadsheets isn’t 100% working though, it’s something that we’ve been talking with their team for a while.

I have clicked on this link and it opened my spreadsheet, so the link is fine. It’s not public though but I have authorized at Blocksrping with my gmail account.
What to do? we won a job at a freelance site and this is the functionality that we were supposed to build - get data from harvest api into spreadsheet and then to bubble. I know we can use the api connector now to pull data from harvest directly but the client needs the google sheets.

I think blockspring requires it to be public no? Otherwise we can’t control what Blockspring returns.

No, for “read spreadsheet” they don’t require it to be public and they have an authentication with Gmail account when configuring the block. I’ve done all that and when I run the test it works fine, both on Blockspring site and from within Bubble’s plugin configuration window…

Well that’s what Blockspring returns, so check your keys, etc.

@levon what’s the issue that you’re running into with the Read Worksheet block?

I have explained everything here including all the screenshots. When I initialize the block with Blockspring and run it I see the results from the spreadsheet, when I try to get the records in Bubble the table is empty. I have tried also making the spreadsheet public but that didn’t change anything.

@emmanuel @Paul why don’t you guys work this out together? Or if it’s not supported remove it from the offered services because it’s misleading. I have promised the client to do this functionality and now it’s not working.

We’re going to add a way for users to see the error messages in debug mode so that you can see why it’s not working. In this case it’s about having access to the sheet, so I would try changing that and see.

as I mentioned above, I have made the spreadsheet public and it still didn’t work. I would appreciate your help, as this is quite a demanded feature by clients.

Looks like you changed the page. We can’t help if the element is gone.

Hi All,

If anyone is having issues with this, this video may help. it essentially shows you have to leave the worksheet ID as zero within bubble and not the actual name of the sheet.

very nice video… do you have any other link to suggest how to create data in bubble and then send them to Google sheets?