Forum Academy Marketplace Showcase Pricing Features

Google Sheets and Blockspring Search Column

I’ve been having trouble implementing Blockspring in bubble to pull dynamic data from google sheets.

I know there have been other forum posts about this but I have read those and tried to get some thing to work but unable to do so. The latest one was also in February and I’m sure things have been updated since then.

Currently, we have Zapier set up to shoot things into a large google sheets database that has a lot of connections with other zaps and therefore we need to keep it on google sheets. However, when trying to set up Blockspring the debug window throws this result.

Weirdly, it works when setting up the block and I’m wondering if I’m setting it up wrong on the bubble side of things:

I’m recreating the problem into the forum app here https://bubble.io/page?type=page&name=google_sheets_integration&id=forumapp3&tab=tabs-1

On creating it in the forum app I’m getting a file_id error even though I’m using the same file Id that was in the plugin install helper shown above.

Any help would be really appreciated!

I had the same exact issue recently.
After taking a look at your app you have the same problem I did, the google generated file id contains a _ object

The _ object looks like isn’t supported by either bubble or blockspring.
All you have to do is reupload your spreadsheet to your google drive and hope that the unique id won’t contain a _ object.
For me the second generated link had no _ in it and works fine.

Cho,

Thanks for the prompt reply. Yikes that sounds awful. We have a lot of integrations tied into the spreadsheet. Are there any other workarounds?

Best regards,

-Isaac Summers

Why can’t you just download the current spreadsheet and upload it again?

I’m not sure about any other workarounds.

Cho,

Basically, we have multiple zaps set up to either push data into that spreadsheet or trigger off data being inputted into the spreadsheet. By doing this it will break all those integrations because I believe Zapier hooks onto the id of the google sheets.

I actually just tried making another test sheet with the id:

1cfAb0dUIT02YSPF20D3m185-sJ9KA5CsxcwFnFgwPaU

and that one is also not working. I’m pushing it into the forum app. It’s still giving the file_id error

That’s weird. I’m not sure what’s wrong then.